Flat Blender rig bones are out of place once imported into studio and would appreciate help resolving this issue

I want the bones to be properly aligned on the flat mesh and not offset.

All bones properly work in blender.

The bones of the flat mesh is offset to the left which is impacting the deformation. It is supposed to be aligned with the mesh as seen in the blender images below:




I’ve followed different videos such as How To Make An Animated Cape | ROBLOX Skinned Mesh Tutorial - YouTube , Roblox Mesh Deformation | Tutorial - YouTube and many others, but it always ends in the same state when I import it to studio.

I’ve tried exporting in different sizes via blender and changing the positions of the bones via studio and blender. Neither has come close to fixing my issue

Keep in mind this is my first time setting up a blender mesh rig for roblox.

So I guess no one else has ever had this issue huh…


You need to move the bones yourself.

When I try to move the bones in studio they start deforming the mesh


Unless there is a way to disable deformation so that you can move the bones closer I don’t see that being the fix.

I think I may have found the solution to this issue.

In Blender all my bone Y values for the head and tail were set to -0.000178.


After setting them all to 0 it seems to have fixed my issue. However I won’t set this as the solution until its tested further.