"FMOD 30: Invalid object handle was used. during getVersion"

This error popped up when I started a play solo session on a game with team create enabled:

I closed the game tab, tried rejoining and it told me to close studio and try again before it could even connect to team create. After restarting studio everything seems to be fine. The error occurred on this place. I had the following beta features enabled:

  • Game Access perms
  • New Lua VM
  • UI Gradient beta
  • Script editor folds behavior beta
8 Likes

Thanks for the report, I’ll look into it.

5 Likes

Just got the same error, and had to force close studio.

@Doctor_Sonar I found a way to reproduce this; it’s related to a bug that occurs whenever you run a separate-window test (Pressing F6 or F7)
Whenever I run a separate-window test, my console is spammed with asset loading errors (all but the last three digits are redacted for security reasons):

This is on a Team Create place, and assets on this list include those uploaded to my library, my team member’s library, and the group library, so it seems to apply to all sounds regardless of who uploaded them.

If I run a same-window test (F5) afterwards, it works just fine. However, if I instead clear the console output, and then run a same-window test (F5), I get this error and have to force close studio

Although this bug in particular is obscure, the console spamming is not, and is kind of annoying to deal with (hence me clearing the console not knowing it would crash studio)

1 Like

Just started getting this issue. The only fix is closing and reopening studio. It is becoming quite annoying as it seems to happen very randomly, with most times I start a solo session working fine.

I have:

  • Game Access Permissions
  • New Lua VM
  • Script Edftor Folds Behavior Beta
  • Insert Object Streamlining
  • Packages Permissions

I’ve never seen this before today, and it’s happened three times today upon pressing Play.

Studio hangs in this state and must be force quit.

Console output:

22:40:29.872 - FMOD 30: An invalid object handle was used. during getVersion
22:40:29.930 - FMOD 30: An invalid object handle was used. during getVersion
22:40:34.818 - Infinite yield possible on ‘CoreGui.RobloxGui:WaitForChild(“Modules”)’
22:40:34.820 - Stack Begin
22:40:34.820 - Script ‘LoadingScript’, Line 17
22:40:34.821 - Stack End

edit: this is happening roughly every 5-10 times i press play now, which is a major inconvenience.

2 Likes

This happens for me too.

When in a Team Create, sometimes when I press F5 (to play) after switching to my explorer tab, I get thrown the error “FMOD 30: An invalid object handle was used. during getVersion”.

This just started happening recently. Can’t find a crash dump file with this. It leaves me in studio but unloads everything in explorer and doesn’t let me see anything.


2 Likes

Happening again.

6 Likes

Been experiencing FMOD 30 errors for the past week or so. It’s getting to the point where it happens almost once an hour now. I’ll look into reinstalling studio and hopefully that will work.

2 Likes

This just started happening to me. Makes it impossible for me to easily test my scripts now.
The error started right after I did a separate window test. I need to re-open studio for this bug to stop.

https://gyazo.com/3d115125160c4f92a4f007870efd8c4e

2 Likes

I’m also encountering this issue now.

Is there any news on this?

1 Like

It just started for me today, also on a teamcreate.

1 Like

Have been getting this lately when starting Play Solo from a team create-enabled place. Studio remains on a blank skybox with no explorer/properties/etc until I restart the whole program.

1 Like

I reported this on the internal slack, but also want to say I see this every 2-3 days of studio usage.

2 Likes

I have not seen this error ever since it happened in December, however occasionally when I zoom out with my mouse wheel unrestrained (there’s a button to lift the snapping mechanism and allow it to scroll super fast freely) I hear this weird beeping noise while it slooooowly zooms out. I’m not sure if this is related or not, but definitely worth mentioning.

I keep getting this still, along with “Failed to load sound” errors when switching back and forth between Start Server + Players and Play Solo in my team create place. I keep having to restart studio when it does freeze do to this issue.
image

After yesterday(?)'s studio update, I have stop getting FMOD errors. However, I am now getting

image

I do believe this new crash message is linked to the FMOD error as it also happens at the same interval (1-3 times a day) and usually after I start a few test servers in studio (and get spammed in console for failed to load sound)

Anyone else experiencing this?

1 Like

Funny enough, a few minutes after I posted my last response, I had Roblox crash again with the same exact message (“An unexpected error…”)

I ended up checking Studio logs and concluded that this bug is indeed the same FMOD 30 error.

image

Not super related but on studio restart, Roblox attempted to upload the error log but it ended up being HTTP 500’d. :man_shrugging:

I’ve also been having this error pop up whenever I play solo. Same beta features as EncodedLua. Its happened three times within an hour of work.

5 Likes

I’ve been working on this; there should be a fix coming soon.

8 Likes