Fog only showing up in studio

Greetings. Currently developing training grounds and for the first time an extremely annoying bug showed up. It’s never occurred before but will not go away as it is appearing in all of my studios at this point. The fog setting is making beautiful fog appear in my studio, but when I click play it doesn’t show up in-game. It does not show up in the published place either.

For reference:

Any tips to fix this?


I got issues of studio lot of times and them was caused by plugins, did you installed a plugin with a virus?

Edit: or isn’t a virus, maybe as @Criminimin said, it’s a script (Maybe made by you) hidden or instead of virus from a plugin, maybe it’s a lighting/landscape/graphics plugin that autosets the fog settings


Check your scripts. Your scripts or localscripts may be setting the fog properties.

There are no-scripts currently in my game.

I have downloaded no new plugins in the last 3 months.

I can’t reproduce this, are you sure you do not have a plugin that affects fog? What are all the plugins you have?

Do you have a script that sets a day/night cycle?

I experienced the same problem as you and I found that my fog settings were being overridden by a script that I had installed for a day/night cycle. The day/night script was executing a different sky setting to the one that I was expecting, as the game’s lighting settings had been determined by that script. (The script had been operated to run a different lighting condition.)

Hm, weird.
Have you tried this on a new baseplate?

Sadly, I have.
I’m actually afraid of opening old games in fear of them having the same fate which would ruin aesthetic.

Try creating a new baseplate and check if this happens on other places or if its just on that single place.

Bit of a guess, but it could have something to do with your edit quality level compared to your in-game quality level, could see if changing that impacts anything?243fb2b3eb2fb52dcaaea9e00f5c9d17

1 Like

It does not, both my settings are on the following:
Quality Level: Level 21.
Edit Quality Level: Level 21.

In-game settings are on graphics level 10.
I tried messing around with all three by changing them at different intervals - to no avail.

1 Like

Issue is still prominent to no avail.

There were some hidden scripts that automatically set the fog to disappear in Local Player scripts. Thank you - took me way too long to find.