Fold shortcut (left arrow) not working in some cases

As detailed here, to refold an unfolded item in the explorer window, the left arrow is not working in some cases, as when returning from a deeper tree, for example.

r

Baseplate.rbxl (23.9 KB)

You can simulate the same by using the project above.

Hey @rogeriodec_games, sorry I’m still not able to identify the problem. Would you mind listing out step by step what you’re trying to do? Here’s a video showing how it should work

1 Like

Repro

  1. Download the project in the OP
  2. Ctrl+P search for WeldConstraint
  3. Click on some Weld
  4. Press left arrow some times and you’ll notice that it’s not closing the trees, as shown in the gif.

This is what I see

2 Likes

In the second 10, when the cursor goes from the second WeldConstraint up to the Welds folder, I think you are pressing the left arrow, right?
But then there is a 1-second delay and then the folder is collapsed. Are you pressing another key to collapse this folder?

Always include your OS in your bug reports. I can repro this issue on my Win10 device, while @darkmodeonn tried to repro it on a mac device. I would therefore assume this is platform-specific.

Have you tested in Windows 10?