Format Selection does not indent on multiple lines

When using the “Format Selection” option in the script menu in Studio, it does not indent when a statement spans multiple lines.


  • Type a return statement, but have it span out multiple lines by using ‘and’, ‘or’, etc.

  • Now highlight the code and use the format selection option. The code will not be indented and a warning will highlight the code stating to “Statement spans multiple lines; use indentation to silence.

  • Additionally, if you attempt to manually indent the code yourself, then use the format selection option again, the same result will show and the code will un-indent itself.



Gyazo recording demonstrating the bug


Thanks for the report! We’ve filed this internally and we’ll follow up here when we have an update for you.

1 Like

I am in the process of checking over bug reports and following up on some bugs that haven’t received any activity in a while.
Is this issue still occurring or can you confirm that this bug has been resolved?

Just checked again and seems to be fixed now. Thanks for the follow up!

Awesome. This issue should now be resolved! If this issue is still occurring, please create a new topic for us to look into.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.