FPS drop after Playing in Studio

If you open up any place in Studio and then press Play or Run, and then Stop the session, it’ll drop the FPS down to 20 FPS or sometimes 4.5 FPS in studio. It is not laggy during the session and only drops the FPS down when not playing or running. This only happens after a play session and persists until I close the place and open it up again.

This started happening 2 weeks ago.

Ryzen 5600x
32GB RAM
RTX 3080

8 Likes

Same here, ALL of my models in my game were already grouped, so I can avoid lag, ah, that didn’t help. If someone has a solution, PLEASE send it here, it is super annoying, and I stopped developing for a few days because of this. For me, it is not just FPS, it is also internal lag.

1 Like

I had this issue last night, and I kept getting lag spikes every .5 seconds. After I restarted studio, everything was fine.

1 Like

Hello! I can’t seem to be able to reproduce this. Can you please list active Beta Features, and confirm whether the issue continues on occurring? Thank you!

2 Likes

0 lag for me. Maybe just you…? Possibly your internet
Core 17 10th gen
24GB ram
GTX 1660 SUPER

1 Like

I get the lag when i change things like lighting settings or things like sunrays or atmosphere via a local script. I also have volumetric clouds in my game and i made “volumetric” lighting.

I have the same problem sometimes

It happens without any beta features and it’s still happening.

1 Like

Thank you for the info. We’ve filed a ticket to our internal database and we’ll follow up when we have an update for you.

4 Likes

It’s weird. I’m having it too, and it is lagging very badly and my FPS drops dramatically.

Same here. I started having this issue since probably december of 2020. As such, developing on larger scale games has been more difficult for me due to the lag.

(This is probably unrelated, but I have been experiencing server-sided replication lag to the client, such as tweening, script parsing, physics, basically anything. It could range from a split second delay to full on two second delays, as shown here.


From the NVIDIA Control Panel, inside Manage 3D settings I set the Vertical sync to Off. Which fixed my problem but this is still a bug that Roblox should address.

1 Like

I was experiencing something very similar to this, but I found a fix (at least for my own case).

Whenever I started studio, it ran fine. It also ran fine in play solo, but if I tested once then the editor became unusably laggy. It was also lagging in the script editor. This started when I built a new PC, but the issue wasn’t hardware, it was just some misconfigured settings (at least changing settings fixed it, it’s possible that other hardware doesn’t experience the issue regardless of the settings). For context my build is:

Ryzen 9 5900x
GTX 1080Ti
32 gb ddr4 @ 3600mhz
ROG strix x570-f
Windows 10 Home

The monitor was a VG27A.

I messed with a few settings, and finally found that disabling g-sync for windowed applications fixed it. I’ve had other people anecdotally say that this solved the issue for them as well. If you don’t have g-sync you can try to disable global vertical sync, or freesync if you have it.

To change your g-sync settings, go to the nvidia control panel → Set up G-SYNC → Enable for full screen mode:

1 Like

I don’t ever seem to get this issue.

Specs:

|Processor| AMD Athlon Silver 3050U with Radeon Graphics 2.30 GHz
|Installed RAM| 4.00 GB (3.38 GB usable)