FPS Hands not animating?

I decided to make a FPS gun for fun a few hours ago- but I ran into a problem where the hand model wouldn’t animate.

It works perfectly inside the animation editor, but when I attempt to run it in-game, it doesn’t work
I’ve tried debugging the issue, both by using an AnimationController or an Animator instance inside of a Humanoid, but neither work!

What’s interesting is that it IS playing, but it doesn’t show at all.
I’ve been searching everywhere for fix but I can’t find one :pensive:

Screenshots of the model:


Here’s some of the code that I use to run the animation, although I did make a script inside of the model and tried creating the animation with it but I still get the same outcome.

are the arms anchored???

The model itself works perfectly, it follows the camera and does everything I want BUT animating.

did you happen to weld the arms in place?

like i said earlier; i can animate it with the animation editor; it just doesn’t play for some reason. Even with a AnimationController w/ a Animator or vice versa with a Humanoid… it doesn’t work

I also tried removing the gun model to see if it would change anything, but nope

Did you possibly change the name of the arms and the gun, AFTER you finished animating?

Day later and it wasn’t actually the code lol
I’m not sure why but I set all the animations (other then the Idle) to action 4.

Setting them back to action 1 fixed the issue. Thanks for the help to those who commented!

1 Like