Future is Bright Flickering Issue

So I’m currently having a few problems with Future Is Bright technology, the light seems to flicker once you get closer, it also happened with the world’s lighting in general, everything seemed to flicker and it seemed a bit glitchy. This is an example of what is doing, I do not know if it’s because of the parts’ sizes, or the point lights’ settings, like how bright or how big the range of the light is, it could also be those little sticks that are in front of the lighting, or maybe that the lighting is colliding with that neon tube there you see.

Gif - Screen capture - a8f01a1355d0660b1522ac6f9b76521d - Gyazo (I cannot post the vid/gif through here)

Why is it causing this? what should I do to fix it? is it Roblox’s fault? I don’t really have an answer to all of these questions, but I’d love it if you guys could help, thanks!

If you need extra information, please tell me. (I do not longer have the light’s settings)

6 Likes

Future lighting is still a bit buggy, I would use ShadowMap until Future is fixed and supported.

3 Likes

Going off of what @AwakenedElemental has said, Future lighting is still a little buggy. The more light attachments that you have the buggier and glitchier the lighting will get.

2 Likes

That- actually makes sense, there’s a lot of lighting parts probably making the game glitch. Thank you! I’d just- wait I guess, though I’ll soon have to give out the commission, I guess I’ll finish it with shadow map lighting, and until Future Is Bright is fixed, I’ll change it and edit it a bit. Thank you all! I wish I could add 2 solutions. :smile:

4 Likes

As I found out fairly recently, disabling shadows fixes the flickering issues completely.
Granted, this of course breaks shadows as well, but in cases where shadows don’t matter as much, (such as where you have terrain in large quantities), you can still use it.
This at least allows you to more or less keep the look of the game the same.

It is still rather unfortunate that this borderline game-breaking bug still exists, though… :frowning:

3 Likes

Indeed! though you got a point! It could fix the shadow! sometimes I want to use voxel type lighting while having future is bright type lighting on some areas.

2 Likes

Yeahh, but changing the lighting engine to something like Shadowmap still breaks stuff sometime. For example, here’s an image from a project that I’m working on right now:

This currently uses Future lighting. If I were to change the lighting to something like Shadowmap or Voxel, this happens:


The shadows break reallllly hard, and there’s really nothing we can do in such cases.
And since this area is a fairly important part of the game’s experience, you can probably see why it would be so gamebreaking…

I don’t know, maybe I’m missing something small that could fix this issue?

2 Likes

I honestly don’t know until they fix it or one of us finds a way in the process of building a game.

1 Like

Simply disable the shadows there, have a go at contacting the Developer Relations team about it via a bug report. Another alternative is just to utilize a different lighting technology in the meantime.

1 Like

My best info I can give you, Keep it future and report the bugs. If less people use future lighting cause its buggy but if instead use the lighting and report and bugs or suggestions we may have then we can make Future Lighting better and a smoother experience for all.

I currently have 2 games using future lighting. One of them is a cartoon game and the other is a roleplay so that’ll involve lots of lights colliding with each other and a town which will also be lit up. so we’ll have plenty of lighting bugs to report.

Plus, First day the lighting came out I wasn’t able to run this game here and now I can run it perfectly fine at full graphics 60 fps. The lighting has come quite some ways and the only way we can improve it for the better is by reporting these bugs and trying to find a solution to the fix.

There is one word to sum this problem up: Optimization, but good news! There are a couple of ways to optimize a map to get your future map working well.

The first way: Reduce the number of shadows preset.

Not all objects in a scene need shadows, you should choose which parts should cast shadows and which shouldn’t. Smaller objects usually do not need shadows.
Here is a simple script to disable shadows on smaller objects, and collisions on tiny ones.

for i,v in pairs (workspace:GetDescendants())do
	if v:IsA("BasePart")then
		if v.Size.Magnitude <=6.5 then
			v.CastShadow = false
			if v.Size.Magnitude <=3 then
				v.CanCollide = false
				end
		end
	end
end

The second way: Reduce the number of lights in the scene.

Let’s say theoretically, you had a room with 5 circular lights. You might want to put a point light into each one of those lights or you could have an invisible brick that casts a single larger light as shown in the picture. (It also really helps to turn “cast shadow” off!)


A string of lights can often be replaced with a single strip.

Thanks for listening to TED talk about Future lighting optimization, and I hope it helps you in the Future. (Pun intended)

1 Like

This happens all the time to me. Just change your Technology to anything else, then switch back to lighting. That works all the time for me.

They have patched it now, but thank you for finding a solution to this problem. Really appreciate the effort and being there for the community. :+1:

I’m not sure where else to post this but I’m experiencing some weird rendering issues with shadows

https://gyazo.com/3f5913d99cbc41a1078b685a11405339