Future Lighting Broken (Studio and In-game)

There’s been about 5 reports recently of broken Future Lighting, and I’m here to make another.

As of around three days ago, the Future Lighting service is broken. While in other lighting technologies, point lights, spotlights, and surface lights all work as intended, Future Lighting breaks these lights as if they have become disabled.

For example, here is a lam with Shadow Map. Below is the same lamp using Future Lighting.

There has been a count of different suggestions, such as changing the rendering settings within studio, but none of these seem to work correctly. I’ve searched throughout studio’s setting myself and still could not find a way to get future lighting working properly.

As for “in-game,” future lighting seems to have broken in-game, too. Playing or running in studio does not force the lighting to be properly rendered, and neither does playing on the website. For example, here’s a screenshot of the “DOORS” lobby, which uses future lighting.

Are there any known ways to fix this problem? I believe it’s a bug on Roblox’s end, but I don’t want to start pointing fingers before being sure I’ve attempted everything.



Future lighting isn’t broken.

Must be something on your end.

I do not think that he has altered anything, I say this because I also had the same error and did not even touch anything, in addition there are more people who present said event


Might be a bug from an A/B test going around.

1 Like

Me and my co-worker have also been having this issue on our place. I tried playing around with the rendering settings in Studio also, but it didn’t work. The in-game future lighting on “get paid to vibe” doesn’t work either. Really hoping that a fix comes out soon.

1 Like

I’m one of the people who’s experiencing this weird problem although some people said it’s fine on their games/studio, which I find weird because this problem occured after the recent update.

1 Like

I thought I was the only one with this issue. Guess I’m not.

Lights just no longer work at all (for me) when a place is using Future lighting, both in Studio and in game. No idea how to fix this.



I have same problem in studio and in game.
Seems like everyone is running into the same issue with Future Lighting.
This looks like a Roblox bug so probably we need to wait Roblox fix this problem.
For now, go in game setting and set graphics low is the way to see in game.

1 Like

It’s probably the matter of GraphicsMode being set to OpenGL or some other engine. You can change this setting to anything other than OpenGL. Vulkan should work. After this, restart Roblox Studio, and lights and shadows should work again.


The only reason this works is because when your graphics levels are set low when future lighting is being used, the lighting technology switches to shadow map automatically.

1 Like