Game breaking with no errors

So I made this bus system for my new story game called Arcade Night (Story) and it was working all good and perfect until 2 days ago…

The worst thing about this problem is that it does not print anything in the output and just randomly stops.

Here is the main code:

It gets stuck at “TELEPORTING” forever even though there are no errors.

I tried some debugging and printing in the game to check if there is any error message in the pcall function, but nothing seems to work there too.

I checked for memory or script leaks, everything seems fine.
The “Teleported” RemoteEvent only shows a transition to the client.
I tried asking some of my friends and none of them could help me out :confused:

This only happens sometimes and sometimes it just goes out perfectly as intended.
I am just shutting down servers now and then to refresh them so players are not stuck in the broken servers forever.

Any help will be really appreciated as I’m stuck on this since 2 days now.

(If you can and want to take a closer look then you may DM me at my Discord: Eco Crash#1000)