Game did not saved

I don’t know which topic to put this in so I put it here

Yesterday I spent almost all day creating an update for my game, and today I published it then wait until it was saved and then closed the window. Turns out it didn’t save, and there is no auto save files created (which was weird considering I had it open for like 10 hours)

Is there any way to get my stuff back?

check the version history,

  1. go to the game page
  2. click the 3 dots
  3. click configure place
  4. go to version history

Any time studio saved, it leaves a snapshot there, can just try checking the most recent, or around the time where you were working, if else, not sure

It did not leave a snapshot there sadly

1 Like

Check your local autosaves folder:

Edit: I see you already tried that.

1 Like

dang, hope you can recover fast : /

Mind sharing the game btw, love checking new stuff out

didn’t end up finding anything. i’ll try researching a bit later on stuff i could try

I’m still working on fixing up a bit of bugs in my game as a lot popped up recently and made it a tiny bit unplayable. I’ll send it to you tomorrow morning-ish (eastern time) probably

Did you check the auto save files on studio or did you look at the auto save files manually?
Sometimes when you open it manually (like using the File Explorer) it doesn’t appear but if you open it through studio the files do appear.

I’ve looked through this thread, but no of that really worked. My entire game deleted itself, reverting to a previous version still has the entire game deleted oddly enough, and I had no saved versions. I noticed when I play tested that my map was gone, so I published it to studio left the game rejoined it in studio and it was all gone.

I’m on a Windows 10 pc

I got the same problem just now, I can’t believe there’s no autosave in Studio.
You can try to delete the game cache in studio, and reopen studio to see if the game scripts is still there.

There’s always a way to get a previous version of the game, you just need to open it from studio or the website. Even content deleted games can be recovered with this.

I ended up finding it, thanks. Though originally it wasn’t working.

There is autosave in studio, but maybe this happened to a few yesterday where it just didn’t save at all?