Game doesn't function out of studio but works in studio

So my code obviously works but,
Out of studio:
In studio:
I use a sketchy Anti-Saveinstance I made that works but I relised I was moving the things instead of cloning it but now everything but the tool works in game but it works fine in studio, The tool is equipped with Humanoid:EquipTool in a localscript which worked before that small change. The tool still goes into StarterGear. I have pressed publish many times and shutdown the servers but still no change. Any help?

Without seeing your code it is hard to tell, but there’s a handful of things that can cause this. Can you tell us what errors you are getting in the console?

Nothing, I am getting no errors when I didn’t change any code besides changing

v.Parent = p.StarterGear


v:Clone().Parent = p.StarterGear

Can you please post more of the script? I think I might have an idea of what your problem is but need more info to be sure

	for i,v in pairs(game.ServerStorage.StarterPack:GetChildren()) do
		v:Clone().Parent = p.StarterGear
	for i,v in pairs(game.ServerStorage.StarterGui:GetChildren()) do
		v:Clone().Parent = p.PlayerGui
	for i,v in pairs(game.ServerStorage.StarterPlayer.PlayerScripts:GetChildren()) do
		v:Clone().Parent = game.ReplicatedStorage
	for i,v in pairs(game.ServerStorage.StarterPlayer.CharacterScripts:GetChildren()) do
		v:Clone().Parent = p.Character

My entire Anti-Saveinstance, The tool worked before I added the simple :Clone() to this

    for i,v in pairs(game.ServerStorage.StarterPack:GetChildren()) do
        v:Clone().Parent = p.Backpack

Not sure what may be causing that issue you are having (you could try adding a p:WaitForChild("StarterGear") and see if that helps), but here’s another possible workaround you can try. Replace the first for loop with this and it will manually put the tool in the player’s backpack every time they spawn.

The same thing happened, I don’t get why it works in studio but not in game, It already worked in studio but it still doesn’t work in game

I still don’t know why this isn’t working, It works in studio but everything but the tool works ig

Get rid of your Anti-SaveInstance. It 100% doesn’t work against exploiters and it seems to cause more issues than solutions for your game.

Well, Something made my tool not work in not studio, I just removed this line but it still isnt working out of studio

Are you using RemoteEvents to create the blocks?

Yes, I am doing that and it works in studio so I don’t see why it wouldn’t out of studio

I fixed the bug, It was that in studio the Humanoid:EquipTool was working but out of studio it wasn’t, I just made the “Play!” button do Humanoid:EquipTool