Game freezes when joining

This is the second time I have asked this question. Didn’t get a solution the first time.

When I attempt to join my game, it will just freeze. There are no loop scripts, no output errors, and no viruses (I don’t use free models & all the plugins I use are the official ones)

Any help would be great :smiley:


I feel like this is sarcastic…

No scripts aren’t working. If you read the post I just say that none of my scripts are causing the freezing. I can’t tell you what’s wrong because I don’t know what’s wrong.

I said there were no output errors which would be caused by scripts. There are scripts running but they aren’t the problem.

It isn’t the models, the pc, the scripts, or my plugins. It’s something else.

No scripts aren’t working = all scripts are running and working

I phrased it terribly, my bad.

Do you remember what changes you made when it started happening? Also does it only happen in studio or does it crash in public servers as well?

It doesn’t crash in studio, only normal place. I should’ve clarified that in the original post, my bad.

It has been crashing for over 2 weeks, the only changes that have been made were parts being added.

Okay so if it freezes then gets unfrozen after a second then that is probably your computer because the same happens to me sometimes even when I have nothing the the baseplate, spawn and stuff in the lighting.

Nope, it permanently freezes. Only the game too, not the pc itself.

Also, I tried on 4 different pcs, same result for each.

1 Like

Oh dang then must be something that i dont know

The issue is likely being caused by a script that you are not aware of. Check to make sure ALL objects don’t have any script you don’t recognize.

I have like 5 scripts in the game. None of them are freezing the game.

isn’t to much scripts or builds or your pc breaking is it?

used 4 different pcs

less than 10 scripts in the game

the map is pretty small and the builds dont use many parts

alr suggestion go to file then go download the game onto your PC then go on a baseplate load it in then save it as the game that crashes or a new game then see

I have done that already. Same result as the main one

Are you sure that the game isn’t running some performance heavy stuff (PathfindingService / cloning (often))

that’s confusing it shouldn’t be doing that have you checked on YouTube

None of that is running. It’s mostly just a map showcase right now.

If the map has a lot of parts then it would lad, sometimes to the point that is just freezes.