Game freezing for non-windows users when joining

Hi. Around Feburary 11th a game I develop for (Group Recruiting Plaza) started experiencing issues where users not on a windows PC would freeze completely for 1-2 minutes when they joined the game. Strangely enough this issue started occuring when no changes were made to our game, and it does not occur in our development game, which is an identical copy of the main game.

Also, we recently disabled all of the scripts in our game and enabled each script one by one, the issue still occured no matter what scripts were enabled.

This issue occurs no matter the server size or how long the server has been up.

Repo - Simply join GRP on a non windows device and you’ll experience this issue 100% of the time.

In addition, one of our players found a game that seemingly has the same issue however, I’m not sure if the issue in that game is the same issue as ours.


I can confirm that your game does indeed freeze upon joining it on macOS.

I’m experiencing a similar issue. If I join any game on macOS, after around 10 minutes or so the FPS starts dipping below 10, even stalling at times, whereas before it was a solid 60. I did a MicroProfiler dump, and it seems to be getting caught on the replicator.

Here’s that MicroProfiler dump:

I’m not sure if this would be considered relevant to the topic, but I hope that the dump here can solve mine and your issue, as they’re happening at the same context (on a non-windows platform).

PC Specs:
OS: macOS High Sierra 10.13.6 (17G14042) [I have an NVIDIA GPU so I can’t go any higher]
CPU: Intel Core i5-3330 3GHz
Memory: 16GB [4 x 4GB] 1600MHz
GPU: NVIDIA GeForce GTX 750 [1GB GDDR5 memory]


@graviiity Thank you for the report! I tried joining your game and I can confirm it hangs. We’re looking into this on our end.

@InherentBalance Your issue might be separate, the hang that I’m seeing when joining is not in the replicator. Also would you mind posting your dump directly onto the forum? You should be able to upload files


This issue is also happening to my game in conjuction with the 5-10 second hang while loading in outlined in my post on a similar topic here

While I don’t have any technical information other than basic analytics, users from my game have been overwhelmingly reporting issues while loading into the game. This was made a little bit better by some script disabling / improvements however the core issue still remains.

The issue appears to be more prevalent among users joining on lower end devices, but I’ve experienced the issue a few times myself and my PC is relatively high spec (RTX 2070S & Ryzen 5 3600X)

I haven’t been able to reproduce the issue myself to obtain any useful microprofiler information, however users have noted that they either get stuck in the skybox or load in but no textures are loaded and the game freezes. I can supply any additional information I can obtain if needed.



@Radiakk Thanks for the info! I joined a few times and got some hangs. Based on what I’m seeing I think it’s related, although the hang is in a different spot.


I am able to upload files, but as the dump is 20+ MB, I cannot.

I do have another dump that is only 12.2 MB, and it covers more severe FPS drops due to something being executed every frame.

Here’s a link to the dump in another file hosting website just in case the OneDrive link was not working.

Thank you! I was able to look at both of them. From what I can see your issue is not related to the original issue (hanging during join).

It’s hard to know without more info on the place/context, but it looks like you have a script that is being triggered by something during Replicator::processPackets that kicks off a BindableEvent which I assume triggers a different script, that occasionally takes a long time to execute. If you’re not able to narrow down the issue you can try posting in the Help and Support section, or file a bug report if you think it might be a bug!

1 Like

The game I was playing at that moment was KAT, but this issue occurs on all other games as well.

I am aware that this doesn’t have much to do with the current thread, I just couldn’t post in Bug Reports so I thought this was a good place to put it. Its an irritating issue and I wanted to make it known.
I’m not sure of the structure of the game, but this issue only occurs on macOS operating systems.

I’ve been struggling with this same issue. Well I only noticed this on Mobile but maybe that’s what you mean by non-windows. Xbox players seem to be fine on my game though.

This was supposed to be moved to bugs by the Dev Engagement team:

Initially thought it was related to terrain, now I don’t think so:

1 Like

Got it, unfortunately I’m not able to reproduce your problem. I tried KAT on my MacOS laptop and didn’t encounter the performance issues you described. I think the extra time spent in replicator::procesPackets is just due to some game scripts and seems to be normal. I also don’t see any widespread regressions in MacOS framerate on our metrics.

1 Like

I think that that is because your computer is extreamly weak…

Interesting… maybe just an issue with my NVIDIA driver?
I dunno, all I do know is that changing the graphics quality (minimum or maximum) fixes the issue. I tried reinstalling Roblox several times and I’ve read that I might have to reinstall macOS altogether and I’m not looking forward to that necessarily.

While yes, my graphics card is quite old and from half a decade ago, this issue does not occur on a Windows operating system (of the same computer).

Joined on a 2017 macbook pro. Nearly crashed my computer. This is how it looked when it was frozen. As you can see the preformance specs are at the top.

1 Like

I hopped into your place and confirmed it’s the same as the original issue on this post. The specific piece of the engine that’s causing this is not something I’m directly familiar with, but it’s being looked at!


Thanks so much! I’ve gone through and removed every script in the game and still get the hang, it was sort of a revelation when I tried a copy in a new place and popped right in with my phone.

Again, thanks!!!

ps. luckily I have some die hard fans that will sit through a 4 minute wait to get in! (thanks to you guys too!)


Hmm. I had Roblox Studio open for about an hour and a half now (completely forgot about it until I noticed it was open in the Dock lol) and it seems to not be experiencing this issue. (the issue before would also apply to Studio).

In general, it seems like the issue is an issue no more, thanks for the responses either way.

1 Like

Okay well… there was never a fix, just Studio didn’t take much CPU resources.

Wanna know why it was running with those issues?
Yeah because I completely failed to notice that my CPU fan wasn’t running, so the poor thing was just baking up as I ran Roblox. Changing the graphics quality made it take up less CPU usage, so thats why that seemed to fix the issue.

Long story short, CPU fan was unplugged and as I ran Roblox, the CPU heated up significantly and caused thermal throttling to settle, meaning the CPU underperformed.

I know this is considered filler, but this was funny and had to share it.

[and yes, I did plug my CPU fan back in, so everything is nice and tidy. Issue is officially fixed now, so I’m done here.]

Alright I have a bit of an update, it looks like this is being caused by an auto localization feature which scrapes and tries to localize user facing strings. I think there are very large strings somewhere in your place that the scraper is finding and trying to localize when clients join. We will keep looking into this tomorrow to find a good solution, possibly just limiting the size of strings that we try and localize.