Game Icon Not Loading

(I couldn’t find a good category to make this topic in, nor do I have the Regular role to file a bug, so I’m just rolling with scripting support)

I just recently updated my game, and for whatever reason, the icon is stuck at the “approved” decal:
It’s been like this for the past HOUR (including on other devices). It’s not supposed to take this long, every other time I’ve updated the game icon, it usually shows up within 10 minutes.

I’ve tried uploading different game icons since it might be a moderation issue, but that didn’t work. I even reverted to my old icon (which worked before), and it still doesn’t work! Stupidly enough, the localized versions (other languages except English) of the old icon still show up with no issue.

Another thing I’ve noticed is that the icon shows up in the Studio file’s Game Settings, but never on the website/app.

This is a stupidly frustrating problem. Game Icons are important for first impressions on sponsored/front page games, as well as indicating new updates to returning players. I need this fixed.

If someone can help me or give any tips, it would be greatly appreciated! If you think it’s a bug and have the Regular trust level, please file a report. Thanks!

Someone just posted a post like this earlier but these things could pend much longer if they need to


Certified bruh moment. The minute after I created this topic, I reloaded my home page and the icon is there. Apologies for the unnecessary post.


Yeah this happened earlier, I think all you can do is wait.

1 Like

thats weird, my icon hasn’t loaded still…
but like he said it takes longer

update: it loaded.

1 Like

Yeah my game icon and thumbnail has been pending for the past hour and still hasn’t been accepted…