Game is not working

Hello! I am back with another question, and it concerns with my game not working, like absolutely broken. Everything was okay when I was playing it before, but now it’s just broke.

I looked at the DevForum, looking for a solution. I tried to make another game, and it was still good. I don’t know why this specific game/file was just, not working

Maybe I added something? I tried fixing it, but nothing seems to work. Looked at the f9 menu, still no errors. Can someone look at my game and see what could be wrong? I hope it wasn’t a virus that I put in my game :frowning:

Never Ending [BETA].rbxl (543.8 KB)

1 Like

Hello! The only problems ive found is the fact that the ui doesnt turn up when you go to the ‘Developers’ or ‘Gamepass Shop’. And the floor is a bit glitchy and Im not sure if you have finished the lifts (elavators) yet? I have also looked in the workspace, and im not sure why you have put Everything into a folder. This may mess up script, like the one with the gamepass shop. Im not entirely sure how to write out these scripts, but, im not sure why theyre in a folder, As im checking through the folder, many of the scipts are actually in the wrong place. :frowning: For example, I moved the Cursor script into StarterGui and it worked?

I havent found any viruses :grinning:

1 Like

Oh, I’ve put them into a folder because I was testing things out. But it’s working for you? The ui and stuff?

1 Like

Imma just put them back, and reedit the thingy

Thats strange, I havent been able to do the ui yet, since im not sure where it goes

i will be editing my question, so that everything is where it should be

So if I download this file again, everything should be in place?

yeah, it should. go download it and check. The mouse does not work, for me that is

Hmm, i see, for me the menu buuttons dont work :confused: ill look into this

Well! The custom cursor works. Just not over ui. There are no scripts in the menu? So thats why that doesnt work??? And im not sure whats up with everything else.

So what could possibly be happening? The custom cursor is the problem? As I was testing it, I noticed that the mouse changes to a clicking mouse, yknow? Have u experienced that when you were testing it out?

Well that happens, the cursor works at the top, over no ui. When I put my mouse further down:

But the lobby button doesnt work, nor the other one. there are no scripts inside of them???

there are? I put localscripts. can you look into that?

-I cant find any, anywhere that would hide them

the scripts are in the CameraScript. can you check into that? that would be where the problem is


I have found this, but its right down at the bottom of the script, that may be the issue, if I put it at the top, it may fix, ill test it. (Something above this may be broken)

okay man, can you update me if you see anything that could potentially be the problem?

Ah. I feel your tween may be broken :frowning:

what could be the possible solution to this?