Game not updating

I am trying to update my game.

My game is up to date in studio, but everytime I save it, the game doesn’t update when I press play.

I have tried:
-Shutting down all the servers
-Switching between making the game private and public
-Turning off Team Create
-Closing paid servers

I didn’t update my game before that for a couple of months, so there may be some game settings that need changing in roblox studio.


Did you try updating another game?


Make sure you do Alt + P, or publish the game directly, rather than just saving it. I know a recent update differentiated the 2 a bit.


I’ve sorted it now. Apparently you have to press ‘publish to roblox’ now, it used to just be you’d press save and it would update automatically.

1 Like

I just figured it out haha, thank you anyway :stuck_out_tongue:

1 Like

It’s always been like that. Also, please mark the topic as solved.


No it hasn’t, but I will mark it as solved.

1 Like

Just to give a bit more explanation.

  • Save To File (Ctrl-S) saves your game to a file.
  • Saving To Roblox saves it onto the new cloud feature. You can open the place up as the newest version in edit mode, but the real game servers still use the last published version.
  • Publishing (Alt-P) will save your game to the cloud and publish the place allowing new game servers to run the version you just published.

I Have the same problem but i cant even click update


Mine isnt working either i have published but its still not workin

1 Like

Same but i already click update

I still cannot update my game. It says “Publish Failed”. I have even tried to update other games but its the same story every time. Is there something wrong with the file?

1 Like