Game publish keeps failing

so I’m having some issues publishing my game, each time just getting the “publish/save failed” message. This issue has been around for me for a good few months however it’s been manageable as the game would publish after 4-5 attempts until now when it has just stopped altogether. my game is very script heavy and rather large so I fear this could be causing some of the issues however I’ve tried downsizing, removing some of the larger arias and removing a ton of the scripts but still results in the same effect of many multiple attempts before success. I have also tried, reinstalling studio, publishing it to a new game, relogging in, PC restart, closing ALL programs other than studio, using a VPN and not using a VPN.

the big reason I’m bringing this up now is I had planned to release the update I’ve been working on for the last 8 months later this month. so I was hoping this problem wouldn’t get worse and I could find a fix after but as always, hope does not do me any kindness.

if anyone has any ideas of stuff I can try it would really help. (sorry this was long)


How big is it? ‘Rather large’ isn’t something we can guess about.
Go to View > Performance > Workspace > World > Primitives so you can tell us how many Parts/etc. are in the game.

If the game is too big is it possible to separate it into different worlds so you can basically cut the game in half or more and have different servers for each section?


Maybe it moderating name/description?

91517 primitives, guessing thats too many. im not against splitting the game up but its always been something I considered a last resort because I never liked the long loading between worlds since travelling is something that happens a lot

so ive downed the game to 33778 primitives by replacing it with the one in that was in the game before I was having this issue but it hasn’t caused it to stop so I don’t think its the main cause

Is there any warning printout in the Output window that might point to why it’s failing?

I have this same bug

Every time I try to publish a game update it does not work - Help and Feedback / Game Design Support - DevForum | Roblox

Do you have roblox terrain in your game? If so, how much? Too much terrain can make your ‘place’ file very large and if your internet is slow it will time out after 2 minutes I think. Maybe less than 2.

You can save the file locally and check to see how big it is. If its 50 or 100MB that might be your problem.

nothing, just “publish failed”

i dont have terrain but i just checked and its 58.1 MB. i have pretty fast internet but it did take a long time to upload previously so I think it may be that its timing out. I did always see more success when I had less things open

yep just checked and it fails at around 1:50 - 2:00

Try saving the file locally, then publishing it from the local file.

currently, that’s how my game is saved which I’m trying to publish. its was the only to not lose the work i did a few days ago since i couldn’t publish

1 Like

Do you have a lot of Unions in those 33778 items?
They take up more memory than just Parts.

Is there maybe an issue where a free model or a compromised plugin has inserted a huge script or model that’s hidden inside an obscure folder or service that you haven’t looked in?

Yep, you’re gonna need faster internet, or shrink that size I bet. If its a laptop try a couple locations around town with free internet and see if its fast enough to publish.

When I had this problem I found that I had enabled QOS on my router and that was limiting my upload speed artificially.

Its not really fair that Roblox limits the upload by time and not size. So people with super fast internet effectively have a larger game size limit than the rest of us.

They should let us wait as long as we want for it to publish and not just timeout at 2 min!


Also, I can’t see how its that big without terrain in it. You sure you don’t have some hidden somewhere that maybe you generated at a huge distance and forgot to delete?

The theories of too big file sizes are wrong. Yes, there are limits - but its really hard to reach them.

The Issue is probably Roblox’s fault. My guess is that this will be fixed next few days.

And no, an timeout for uploads are completely legitimate and required.

The limit on file size is very real. The time limit is 2 minutes, the max file size is determined by your internet provider’s upload speed. Do you not get that?

I have a 64MB game, I can adjust my upload bandwidth limit until it fails to demonstrate this.

Roblox could pick a file size and make that the limit and allow devs to wait however long they are willing to wait for the upload to finish.

Dev’s with blazing internet upload speed can use larger place file sizes. That doesn’t seem fair to me.

You can only squeeze so many bits through your ISP within 2 minutes.

Or, if they must use time, make the limit 5 or 10 minutes. I would happily wait 10 minutes for my place to publish if that was the only way for it to complete. (think of remote countries, not everyone has adequate internet speed)


quite a lot of the game is made up of unions. I don’t use any free assets in the game and for a long time have only been using plugins I’ve made myself but it can still check. the game does use a lot of big scripts. the base script for the spell system is over 200 lines and I’ve got over 100 spells done and many of those will have their own separate scripts inside them

1 Like

unfortunately, i only have my pc which I directly connected to our router so its the fastest I’m going to get.