"Game Settings: Could not fetch permissions for universe" (USING BETA FEATURE)

I can’t access the Game Settings dialog at all in my game Welcome to Farmtown while the beta feature “Game Access Permissions” is enabled. Figured whoever is working on this feature might like to know.

The universe ID in question is 1128795217.


same thing has been happening to me too, another beta freature (Lua VM I believe) was also preventing script changes from publishing for me.

1 Like

Is this happening on every open of game settings or periodically?

This happens on every open of game settings with the beta feature enabled.

Is your game published/team create is on?

I’ve identified a potential issue, working on a fix.

1 Like

Yeah, it’s on. Oddly enough, I tried turning it back off and then I got kicked out of Team Create a few times until I turned it back on. I’m not really sure what happened there and I can’t seem to reproduce it, but I’ll let you know if I can at some point.

I still have this issue on any game that I’ve given what used to be the manage permission but is now merged with the edit permission.

I have the exact same issue, but I can access only one which is also in TC as other games.

Can you verify that this is still happening. A fix that was recently deployed should fix this issue

I had trouble opening studio like 3 minutes ago, and as soon as you replied, it worked. I feel that the bug might have also been tied into the opening of Roblox Studio on Mac itself. But it works now. No need to worry.

It appears to be fixed for me.