Game Thumbnail

I’m trying to upload a new thumbnail to my Club Boates game but it never shows up even though I’ve uploaded it multiple times over the past 3 days.

Halp? D:

Uploading the same image over again will make it auto-fail moderation, try changing a pixel, or change it slightly, and it should be able to pass

But it was never disapproved? I’m confused.

It’s a rare issue, but sometimes a thumbnail will simply never appear, no matter how many times you reupload the same image. It’s happened to me before.

Best to just change a pixel and reupload.

Changed a few pixels in two different ways then uploaded both on multiple browsers. I’m not sure what the issue is here.

Having the same issue now. I’ve been charged for 5 thumbnails but only have 4.
I’ve tried uploading images more than 5 times, probably about 9 using IE and Google Chrome.
The images that have been approved have been tried a couple of times, so it isn’t an approval issue.
I have got the 2 ROBLOX images on various tries (the hourglass on page which I assume is ‘wait for mediation’ and a circle with slash on dotted outline page which I assume indicates there is some issue).
Also if I want to upload multiple images it seems like for each image I have to:
-choose file
-upload image and pay $20
-select Thumbnails and go back to step 1

I’m also having issues - I can’t delete any game thumbnails or videos.

Im still having the issue. I’ve been charged 6 times and had 1 image show up. The rest either haven’t appeared at all or shown up as a grey outlined white page with a circle/slash in it.