GameAnalytics not showing purchases

Hello my fellow robloxians.
I am using Gameanalytics to see my Visits,PlayingDevices, Errors and Purchases.
But when people purchase items its not sending even though i call it in the module and it has the correct data in it.
I am using this Model by @DeepBlueNoSpace and i am using it in this Game.
Here’s are as well some screenshots of my code.

anyone got a fix for this? then let me know down below!

Did you make sure to account for the 1 hour current delay (at the time of sending) on live feed and that it only processes from the live feed to the actual main dashboard at UTC 00:00, I use the exact same as you and we both seem to have the same RecordTransaction arguments, so I doubt it’s how you set it up that’s breaking it

you use the exact same module? and yes the robux has been spend 6 hours ago with devproducts but nothing has apeared yet.

Exact same module yes, pcall(function() GA.RecordTransaction(p, 1000, "DevProduct:Plus5000") end) would be what I use inside of the processing of the gamepass itself, not firing an additional event to handle it.
edit(P being the player instance (same way as you got your one))

i have 2 seperate scripts. and since you only can have 1 processReceipt function. i am just sending the same info throug an event to the other script. and i just store the name as Devproducts:Skip_Level, could it be the _ tho?

Looking at the documentation, their examples use _ so I guess that’s not the reason, you could try it without the _ to make sure though.

Live feed doesn’t show anything? it should show within 5 minutes if they don’t have delays

to confirm that i am looking at the correct analytics bar. whats the name i have to pay attention to? your game’s ID /live-feed You should see it in between your player joining/leaving events

active users is totaly not correct

Just give it some time to figure itself out, it’ll eventually realize that all users are gone, do you see anything regarding the “business” event in there? it might still be processing since you tried it recently.
I’ll be heading off soon so I can’t assure you that I’ll be here to respond back.

could you send me a screenshot of what it should look like?

Unable to provide that info ATM, taking too long to show up, will return to this tomorrow if it’s still not resolved, best of luck

1 Like

GA Isnt even sending plays anymore.

Getting the same results too, it just returns No data to send. weird…
edit: I used GA about 5 months ago, not recently so I have no idea if anything changed since I used it.

I use this module too and apart from a few failed events it works flawlessly :eyes:

mindt sending over your module?

seems like its not recording the events

There’s a tutorial if you haven’t already seen it here
I can’t see anything obviously wrong

the problem is the model is incomplete thats why its not sending data.

I doubt it’s a problem with the module if you’re using the latest version

Is there a space in the name? That may cause an issue

Active users here is within the previous 24 hours. It shows how many users have played in that timeframe.