Gateway 504 error while uploading sound cost me robux, sound is broken

On another account, zillion, I’ve been having some trouble uploading assets to Roblox. First, about three days ago, it was an animation I had made in Studio. I got the 504 error once, and a corrupted version of the animation was uploaded twice. I attempted to upload the animation over one of these corrupted versions, but the game still couldn’t actually load them despite the upload being successful. The corrupt versions showed up with this image on the website. However, after uploading over them, the image changed to that of a normal animation despite that they were still not loading in-game. I was eventually able to upload the animation that night.

Yesterday, I encountered the same problem when attempting to upload a different animation in Studio. This time, it took at least five attempts to not get this error message accompanied by the same corrupted upload problem.

Today (April 20, 2020) I tried to upload a medium-length audio file (this time from the website itself.) It cost 35 Robux to upload this. It eventually returned with the same 504 gateway error. When I try to go to the audio’s page, it gives me an error " Bad Request 400 |There was a problem with your request" I can see by mousing over the link in Create that it’s Asset ID is 4924416678. The error should be accessible by going to this link: Tonky Honk Attempting to play a sound using this ID in Studio gives the following error: “Failed to load sound rbxassetid://4924416678: Unable to download sound data”

Despite the upload clearly going wrong, it still charged me 35 Robux for this. Is there some way to get this back? It’s a little bit less than 10% of the robux I have right now (premium 450.)

Also, I am asked, I am logged in as zillion on the website and in Studio. I don’t think these problems are caused by Roblox servers getting confused about which account I am logged in as. It also doesn’t make sense considering uploading still works sometimes.

If there’s some test to see if the bad connection is on my end, I’ll do it. But I’m doubtful that it is since I have been having no internet problems over the past few days and uploading is just a basic internet request like any other.

It’s a few days later and I looked through my transaction history on zillion and it shows that I did not get refunded the robux. My current robux is 380, and I started at 450 from buying premium 450. -35 robux from the purchase outlined in this post. Another -35 robux to try uploading the sound again, which worked.

This could’ve potentially been up to 350 (if I recall correctly) if I had been uploading a long sound file, which is a pretty unacceptable amount to lose from a glitch.