GetBadgeInfoAsync Crashes if Badge Description is Blank

I’ve been struggling with the following error from GetBadgeInfoAsync pretty much all day and just discovered what causes it which is really stupid.

So that error above, which gave me many hours of pain and agony trying to fix, is caused by the description of a badge merely being blank. I can understand why Roblox doesn’t want badge descriptions to be blank, but at the same time, it’s not required that badges have a description. So the error above is caused by me simply uploading a badge and not giving it a description just for testing purposes. The first badges I was trying this with and kept receiving the error were created before badges started using Badge IDs instead of Asset IDs, so I thought maybe that was the issue. So to fix this, I uploaded all of the badges again so that they would use Badge IDs, thinking that would solve the problem, it didn’t and ended up being a pretty expensive waste of time. So then after asking so many people for help, so much pain and thinking Roblox just hated the badges I uploaded, I tried a badge from MeepCity, just to see if I could get the badge info. On the first try it worked, so the issue must’ve been either with my account or something to do with my badges.

@qqtt991 realized that hey, the only thing different about my badges were that they didn’t have a description. So I merely added a one-word description to see if that solved the issue, and it did. Turns out the JSON parsing for GetBadgeInfoAsync crashes if the description is null, isn’t that just great. Many hours and much Robux wasted later, and it turns out the issue was because I didn’t give my badges descriptions since I was just testing them to see if they worked and was going to give them descriptions later… nice.

Repro steps: Upload a badge without a description and try using GetBadgeInfoAsync with its ID.

How often does this happen: 100% of the time


Sorry about the inconvenience. It will be fixed as soon as possible.