GetMarkerReachedSignal's code sample uses GetKeyframeReachedSignal, which doesn't exist

https://developer.roblox.com/api-reference/function/AnimationTrack/GetMarkerReachedSignal

The code sample:

    local player = game.Players:GetChildren()[1]
    local character = game.Workspace:WaitForChild(player.Name)
    local humanoid = character:WaitForChild("Humanoid")
     
    local anim = Instance.new("Animation")
    anim.AnimationId = "rbxassetid://437855404"
    local animTrack = humanoid:LoadAnimation(anim)
     
    animTrack:GetKeyframeReachedSignal("FootStep"):Connect(function(value)
        print(value)
    end)
    animTrack:Play()

Uses GetKeyframeReachedSignal, which doesn’t exist (not to mention, it isn’t what the article is about).

8 Likes

Docs still outdated on this. From: Sync footstep sounds with math?

1 Like

Just ran into this myself, who does one contact to try and get this updated?

2 Likes

I don’t know. Any news? It’s still not working for me.
PS. I believe that I didn’t make any mistake
Bump

Still doesn’t exist, gah… I wonder when it’ll be fixed.

Hi guys! This issue is still a thing.

Use GetMarkerReachedSignal instead of GetKeyframeReachedSignal to fix the code btw.

1 Like

The code example doesn’t use :GetMarkerReachedSignal() at all, and references a function that doesn’t appear on the AnimationTrack API reference page.

I’ve looked into KeyframeMarkers and there’s an error in their code snippet as well:


As you can see in the blue highlighted portion, the event it calls is for GetKeyframeReachedSignal when it should be GetKeyframeMarkerSignal. I’ve tried both in studio to be sure and only the Marker event works.

Hey guys, sorry this got buried and ignored. I’ve went ahead and updated the code sample, which should be visible soon. You can check out this post for the updated code sample and a link to an example model which should answer your questions:

3 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.