Getting frequent BSODs while trying to use code editor in Roblox Studio

Hello. Let me start with the fact that I have been developing games on Roblox since 2020 and I have never encountered an issue like this before. I cannot write a short code without getting a blue screen in less than a minute (I can rarely work for around 30 minutes without the interruption). It even happens in a blank baseplate game. I have tried doing everything from this video: Tutorial but it did not work. Other aspects of Roblox Studio work just fine. The first time this happened was around a week ago. It does not happen with other programs, or even with games like Crossout. I wonder how my laptop can handle a game with realstic graphics but it can’t handle code editor in a “lego games platform” (I apologize for this comparison but You get the point).

Does anyone have an idea how I can fix the issue? I can provide more details if needed. I will get some sleep and visit Roblox Devforum tomorrow. Thank You for reading and have a nice day!

1 Like

what is the error code? also whats the specs of your computer?

I will also include source of the problem included in the BSOD: nvddmkm.sys

CPU: Intel(R) Core™ i7-7700HQ CPU @ 2.80GHz 2.81 GHz
RAM: 8,00 GB (available: 7,87 GB)
Graphics card: NVIDIA GeForce GTX 1050 Ti
Disk: LITEON CV8-8E128-11 SATA 128 GB

Let me know if You need more information.

What have you done to try to fix it? Have you tried the generic troubleshooting steps such as updating your drivers or reinstalling Roblox Studio?

I did that. I can make a list of everything what I tried.

You should do that then. It should of been already stated in the topic but now you know.

Have you tried repairing your system files? If so, maybe try reverting back to a system restore point from before the issue. If the issue continues it might be a case of reinstalling Windows.

perhaps try reinstalling studio? else its a windows error

I ran sfc /scannow command in CMD to fix corrupted files but it did not work, there were no corrupted files.

Everything what I have done:

  • Updating drivers
  • Reinstalling Roblox Studio
  • Fixing corrupted files
  • Doing memory diagnostics
  • Updating Roblox Studio and operating system

Hmm, the “nv” at the start indicates it is a problem with NVidia software i.e. graphics like GPU, did you try updating your graphics drivers through GeForce Experience?

Yes I did and I hope that there is an issue with the new driver so I only need to wait for an another driver update to fix the issue.

I reinstalled operating system in late 2022 and I might do that again if nobody comes up with a solution.

Try rolling back the Nvidia drivers using Device Manager.

1 Like

That is a good idea. Let me try that.

Thank You so much! It worked. I installed drivers from Janurary 2022 and it fixed the issue.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.