Getting the Game Icon doesn't work

I have the following script:

local GameId = game.PlaceId
local GameInfo = MarketPlaceService:GetProductInfo(GameId)
local GameIcon = GameInfo.IconImageAssetId
local PlaceIcon = InfoFrame.PlaceIcon
PlaceIcon.Image = "rbxassetid://"..GameIcon

I even tried with

PlaceIcon.Image = "rbxthumb://type=Asset&id="..GameIcon.."&w=150&h=150"

But the image isn’t showing. Can anyone help me?

Try this

local PLACEID = 1234089431

local Product = game:GetService("MarketplaceService")

local Details = Product:GetProductInfo(PLACEID)
local IconID = Details.IconImageAssetId

local IconImage = "rbxthumb://type=Asset&id="..IconID.."&w=150&h=150"
PlaceIcon.Image = IconImage

if that doesn’t work, may I see the output if there are any output errors?

That didn’t work. Also no errors in the output.

Did u Enable Studio Access to API References and allowed HTTP Requests?

No, but for some reason it automatically enabled itself.

But, since the script is a server script, that won’t do. I have also checked. Any more ideas?

Add another parameter to :GetProductInfo. Add Enum.Type or something like that. Change the type to a place.

Edit: InfoType is the name of the enum.

What do you mean? Can you show me an example, please?

Alright. I fixed it by using a different URL and variable. Thanks everyone!