GetUserThumbnailAsync not working

You can write your topic however you want, but you need to answer these questions:

  1. What do you want to achieve? Keep it simple and clear!
    I want the player’s profile to appear when they join the game

  2. What is the issue? Include screenshots / videos if possible!

  3. What solutions have you tried so far? Did you look for solutions on the Developer Hub?
    I’ve tried to do a remote event from the server to the client which didn’t work. I tried just a normal local script which also didn’t work, and I tried to do a for loop which also didn’t work.
    After that, you should include more details if you have any. Try to make your topic as descriptive as possible, so that it’s easier for people to help you!
    I’ve tried this before and it worked so I looked at old code and it was the exact same thing. I really don’t understand, or maybe there is something I’m missing

local plrImage = script.Parent.mainBank.plrImage
local Players = game:GetService("Players")

local userId = plr.UserId
local thumbType = Enum.ThumbnailType.HeadShot
local thumbSize = Enum.ThumbnailSize.Size60x60
local content = Players:GetUserThumbnailAsync(userId, thumbType, thumbSize)
plrImage.Image = content
plrImage.Size =, 60, 0, 60)

Please do not ask people to write entire scripts or design entire systems for you. If you can’t answer the three questions above, you should probably pick a different category.

1 Like

LocalScript under whatever ImageLabel you have:

local Player = game.Players.LocalPlayer
local PlayerImage = script.Parent.mainBank.plrImage

PlayerImage.Image = game.Players:GetUserThumbnailAsync(Player.UserId, Enum.ThumbnailType.HeadShot, Enum.ThumbnailSize.Size60x60)

You first off were printing the thumbnail, which might error (Idk though.) Also, setting the size to 60x60 on the ImageLabel will end up changing the size on the ImageLabel, not thumbnail!

Other than that, let me know any troubles that may occur with my code! :grin:

It didn’t work here’s the code I wrote

local plrImage = script.Parent
local Player = game.Players.LocalPlayer
local PlayerImage = script.Parent

PlayerImage.Image = game.Players:GetUserThumbnailAsync(Player.UserId, Enum.ThumbnailType.HeadShot, Enum.ThumbnailSize.Size60x60)

whoops not used to doing code in here let me change that

What might cause the issue is the script type itself. Make sure the script is a LocalScript under the actual ImageLabel!

Other than that, it should work, I’m wondering why it isn’t! :thinking:

yep it’s under an image label and it’s a local script. I really don’t know why it’s not working either

Check this localscript code documentation:

I have too, and it doesn’t help. (They basically had the same thing, and it wouldn’t work.)

yeah this doesn’t work either. I copy and pasted the code and nothing showed.

Wait it out, sometimes Roblox glitches. (Actually quite frequently.)

Wait around 5 minutes, and test mine again. It should work, and if it doesn’t, let me know!

Ok. I’m just gonna close roblox studio for now and reopen it to see if that changes anything.

1 Like

Roblox studio? You should allow API services in studio, that’s your problem!

That’s not it, I have it on currently

Test it in an actual game. It should work then.

Well, it seems I have found the problem. My actual roblox profile picture is not showing. Can you send your id so I can test it. Roblox is really screwing me over, I don’t know why my profile picture is blank.

This usually happens when you’re wearing a piece of moderated clothing by the way. Try changing the clothing you’re wearing.

Yeah, sure thing!

My user id is 2965877981, hopefully it works! (Do keep in mind most times, user’s shouldn’t experience this issue, so no worries!)

yep it worked. I really don’t know why my roblox avatar is blank. Do you mind searching my name in Roblox to check if its also blank?

Yep, it’s also blank. Check your avatar, your shirt is most likely moderated.

ohhh I see. One of my items got Content deleted.

1 Like