Glitch on roblox studio

So recently im making a game BUT the problem is my character is like he weld a gun for no reason and i didn’t put any gun in my game if somebody could tell me how to fix this glitch it could be awesome

here the proof
i tried to reset but the problem is i do not respawn

could somebody can response the fastest way possible it would be very cool
thanks you!

-underTV :happy3:


Check for scripts (and tools) that shouldn’t be in your game.
(Do this by searching ‘Script’ or ‘Tool’ in Explorer.)

Also, to prevent this make sure to check if any scripts from free models or plugins could lead to something happening that you don’t want.

I do not put any tools of any gun in-game

and most of the model are my own model so there no script inside
i think it’s a problem from roblox studio because when im playing via the roblox player launcher it’s working perfectly

It’s a plugin causing it then maybe, do you have anything malicious? Something you got from the library like a model or a script or a plugin? Using the RunService and :IsStudio() the script can make it possible to give you that weapon only in studio

1 Like

These are my suggestions, If the error continues you could report it to the support. :smiley:

  • If you have used a free model in your game, check the free model for malware scripts.

  • you can also verify a script that interferes with another and causes this reaction to the player.

  • If your game is not R15 there may be a model that interferes with the snowman suit.

1 Like

I dont think it’s free model like i say i wasn’t using free model most of them are my model i made so there no script inside

there script that do not interferes with another

the snowman is in R6 and not in R15

If any element of the script is in orange you should verify it, Here is an example:

i look at all the script and tried to find the element in orange but i could not find anything

i do not use plugin in my game

because some of them i do not understand

1 Like

As already mentioned, check if you have any plugin related to animations or weapons.
You can check the Breakpoints, Output and Script Analysis too.

there is 0 error and 0 warning

i will try to turn off my pluging

I remove the unless plugin and it’s still doesn’t work

Using the script searcher, look for anything that has the word Character in order to see if there are any scripts that are manipulating the character.

i just removed all the script and it’s still not working

i think my roblox studio is broken

So it’s still dont work i reinstall roblox studio and nope it’s the glitch there

why it’s happening to me?!

This is due to a plugin you have installed, most likely. If it only happens in studio, navigate to the Plugins tab and check through to make sure there’s no plugins that would cause it. If you cant tell, uninstall plugins one by one until the issue stops happening.


Thanks you so much it worked so well!!