Google Chrome freezes when a Roblox game page is opened

Whenever I open a game page on Google Chrome, for a few seconds it works but then that page freezes and CPU used by Chrome increases.

You can see the issue on the gif below: (I am trying to click on stuff but nothing happens)

lol

This issue occurs on any game page, however, it doesn’t occur when using Chrome in guest mode or secret mode and it doesn’t happen on other browsers too. Also, removing all extensions and even reinstalling Chrome didn’t fix it.

It started happening randomly yesterday. I really need this fixed because I really don’t wanna switch to Microsoft Edge. It only happens with the game pages, other pages work.

Edit:

2 Likes

I am not experiencing the same issue, have you cleared your history, cache etc. ? these things will automatically download when you log on to your google account when setting up chrome, hence reinstalling does not actually clear these.

I just did that, the issue still persists.

Have you recently updated chrome before reinstalling? I just checked my chrome version and found that there’s a new version installing.

Edit:
The new version does not create the issue, please disregard.

Edit:
If you recently changed some chrome settings, try reverting each one of those and see if the problem stops occuring. If else fails, try disabling hardware acceleration, if this doesn’t work, I really don’t know what’s going on :confused:

I reset all Chrome settings, and found something, very strange. When I reset all settings, I was logged out of all accounts (of course) and I tried opening a game page on Roblox. Believe it or not, it worked just fine. However, after logging into my account, (Aorda) it started freezing again. At the same time, opening any page on Microsoft Edge with Aorda works.

So, I guess it is impossible for us to solve it. I maybe should just wait for someone from the staff team. But still thanks to you, I was able to fully identify the bug!

4 Likes

Using the most recent version of Chrome, and i’m not experiencing any issues, are you sure it’s chrome’s or roblox’s fault?

I am not sure, it is a weird issue. Chrome opens game pages when I am not logged into any account, but Edge and Firefox can open game pages normally, when I am logged in too. This started to happen out of nowhere a couple days ago, and I had to switch to Firefox.

I have also confirmed that other people are having this issue. (They directly messaged me to ask me if I had found a solution, after reading the topic)

Reinstalling chrome and resetting all settings didn’t help, so I’ll just wait. But it is okay for me now, I like Firefox.

1 Like

Can you confirm the version of your chrome? Maybe that version is broken.

The issue happened on the latest version. I now uninstalled it as I currently am using Mozilla Firefox.

1 Like

I updated chrome, can confirm the latest version is broken.

1 Like

This only applies to certain people, I updated my chrome to a newer version and I am not experiencing the same issue.

Strange, is there something else we are missing?

I believe we’ve checked everything we can. I have a strong feeling this has something to do with extensions though, however as previously stated:

The only things I can think of is that there’s a common extension that’s causing an issue or some Roblox accounts have an issue.

Edit:
I previously had issues with Roblox+ and Stylist so I got rid of them, perhaps these two extensions may be the cause?

@Aorda If you ever give Chrome a try again, could you check the console for any errors that might give us some more details.

Tested without any extensions, it took a little longer before it crashed.
I think it’s a memory leak.

Could leave the console open and try opening a game page again?

No errors or funny stuff being printed in the console, yet it still crashes. Weird.

1 Like

Can you go to this page and check for your chrome crash reports.

Edit:
Link isn’t working, paste this in the address bar:

chrome://crashes

Just reinstalled Google Chrome to check that page. It gets frozen, but it strangely doesn’t appear in there.

I hope the Roblox staff team is investigating this issue.

2 Likes

I have tried as well and could not reproduce the crash… I’m unsure of what version of Chrome I have however I’m going to try and see if it also happens on Vivaldi

Just did it, doesn’t have any information as @Aorda said.