Group revenue summary errors when not the owner of the group

This will be quite a short post, but here we go.

There’s a bug in the group revenue summary section of the group admin page.

Information
I cannot access the revenue summary as it errors, but I can see the line purchases tab.
However, when I own the group, it works. (I tested this by trying to see the revenue summary in a group I have access to the revenue, and in a group I own. While it didn’t work for the one I didn’t own, it did for the one I own)

Happens all the time.

I’m using Google Chrome, and don’t have extensions.

Device Info

  • User agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/75.0.3770.100 Safari/537.36
  • Platform Type: PC
  • Device Type: Computer
15 Likes

This topic was automatically closed after 1 minute. New replies are no longer allowed.

I have this issue too, I can never read the revenue report in my group and I thought it was just me.

Thank you for reporting this!

1 Like

I am having this issue too, some of my friends who are not the owners of the group can see the revenue but some others like me cannot.

1 Like

I’m also unable to look at the group funds of melonslice even though I am the co-owner and I have the permissions. We’ve tried changing browser, logging out and logging back in, changing my perms, etc. It is important to us because we log some of this data into a Google sheet and now, only the owner is capable of executing this task.

Thank you.

1 Like

I also have the exact same issue with the error showing up. Tried it with two groups, not in the owner rank but a rank with the perms. Still couldn’t see it. Tried it with my computer and laptop on google chrome, and different browsers. Doesn’t work.

Both the developers I work with are having this problem, it’s very annoying for them.

We figured out it is the permission to spend gorup funds that does this, not being the owner of the group.

Is there any planned fix for this? It’s a very annoying issue and I’d love to see it resolved, specially since we depend a lot on revenue to ensure our updates did not mess up with the revenue by anyhow, to see if there are improvements, etc.

Noticed this about a week ago however I thought it was just my group perms, a fix would be nice.

I had actually emailed Roblox support regarding this as I’ve had this bug for over a month now. I was told at first that I did not have the appropriate permissions to view the group funds, although I had every group perm. I was then told engineers were already aware of the problem but there was no ETA.

Thanks for the report! We will fix this soon.

2 Likes

I couldn’t see this either before, but I did a little experiment and it turns out I needed the “Spend Group Funds” permission for whatever reason to see the revenue.

This should be fixed now! Let us know if you encounter any issues.

Still experiencing it.

1 Like

I can view them on groups I can spend robux in still (still not owning the group), but I still get the error in groups I cannot spend the group robux in.

Can relate, having it too. It is annoying to not see pending sales etc.

Also still having this issue in groups that I don’t have perms to spend funds in.

1 Like

Just to verify, which permissions do you have in the group that you expect to be able to see revenue with?

This still happens to me as well, I’m the highest rank under the owner rank, have all the permissions, yet can’t view the group’s revenue summary.

2 Likes