Group shouts/announcements not working after update

Hello there, when I noticed the new update for group Announcements released, I was so excited to try it out. It was all working good until I tried to add the same community Guilded server to multiple of my groups which I want all members to see those announcements.

Little did I know, I was about to freeze all my groups’ announcements, and I’m gonna get into that in this post, so the issue can be fixed.

I will give a more detailed explanation of what I did first:
I started by creating a community for my Roblox group, so I can test and see what can be done with this.
After a few minutes, I decided to link my other Roblox groups to the same community, and that’s where things got a bit weird. My first group, is owned by my personal account, however my other groups are owned by an alternate account I made as a group holder. (why my first group is under my main rather than the holder? the group got verified and I don’t want to lose the badge)
Now, the important part is, I had to create a Guilded account and link it to my group holder account. After doing that, I transferred the community to that account, so I can link it to the Roblox group.
Once I linked the community to the Roblox group I wanted to create a new announcement to see what it would look like across all the groups. That’s when I noticed no group was receiving information from Guilded anymore. All my Guilded posts showed up as “announcement in review”, however this review took more than 3-4 hours, without any result. So I thought I was basically stuck with it.

Now, there was a workaround “fix” I found, which was creating new channels in the Guilded community and linking them to Roblox. However, this shouldn’t be called a fix to the problem, because this issue might occur to other people as well, that probably won’t know what to do in this situation. Below I’ll attach visual aids of what I had happening in my community.

Visual Aids:
Guilded: (Announcement stuck in review)

Roblox: (both groups show different announcements despite the fact that I changed it)


Guilded: (More attempts at changing the post, even though it was still stuck in review each time)


Roblox: (Previous post disappeared after I tried to clean the list and try to make new posts again)

Main browser information
Google chrome: Version 123.0.6312.58 (Official Build) (64-bit)

System information
AMD Ryzen 9 7960X3D @4.70 GHz, 128 GB NVIDIA GeForce RTX 4090

Another minor issue I would while using this feature, is that if a post is not approved by Roblox moderation, you need to delete it, otherwise the next post won’t show up either.

Hopefully this issue can be fixed in the future so other creators won’t have to deal with this problem.

If you are facing the same problem, wait for a fix, or try to create a new announcement channel and link your groups to that!

Thanks for the report! We’ll follow up when we have an update for you.

1 Like

Thanks again for reporting this–we released a fix which should prevent this issue from occurring in the future. But please let us know if we missed something here!

2 Likes