Group uploading won't let me edit or find recent T-shirts I created in my group

I made a T-shirt in my group and I can’t find it anywhere. I’m not sure if this is happening for anyone else or if it’s my own fault, but if anyone else could test it in their own group and try to find what they just uploaded, that’d be appreciated.

Things I’ve tried already

  • I’ve tried clicking on “Show” as well but it brings back an empty page.

Have tried clicking on “See all group items” but it brings me to the regular catalog and nothing related to my group.

  • Going to the Develop tab>My Creations>Tshirts doesn’t bring it up
  • Develop tab>Group Creations doesn’t have a tab for clothing
  • Going to Group Admin in the group doesn’t really do anything with clothing

Sorry for your eyes and the messy images everywhere. All I’m trying to do is edit a T-shirt’s price and stuff. (^’:

Alrighty so the only way of finding your Tshirt is by going to your own inventory/avatar editor and going from there.

Can someone fix that

That’s how it has always been. It only gets put on group items once it’s moderated. If you wait like an hour or so, it does appear in your group items.


Really? I don’t remember it being like that at all. Anyway, thanks; feels a bit faulty imo