GUI blocking me from turning camera

Hey guys!

For my guns we have a melee mode in this mode it enables a GUI which allows you to swing up and down.

But the problem is this GUI takes up the whole screen and usually you use right click to move your camera but this glitches that out and then you cant. Is there anyway to fix this


On the GUI, turn .Activated off.

1 Like

What do you mean? I just looks this up and got nothing lol

1 Like

If the GUI you’re on has a frame with .Active enabled, turn that off.


Alright lemme try this. Thanks tho


yes, this didnt work. It still works the same.

1 Like

Are you able to make the GUI Smaller? Thats how I fixed this issue in the past, but might be different now?

1 Like

Make sure all GUIs blocking the screen have .Active disabled.


Hello @Ninjaz_Chimp. I had a similar problem but I have found the solution. By setting the GUI’s property “visible” to false it will not block the mouse where it is. Remember to mark this post as a solution if it helped!


What if I need the GUI visible (they are buttons) but they are blocking me? What can I do? (no i cant scale them down)

I don’t really understand what the gui is for, but instead of making a button like that, you should just do:

local Players = game:GetService("Players")
local player = Players.LocalPlayer
local mouse = player:GetMouse()

local function onButton1Down()
    -- put whatever you want to happen in this function

mouse.Button1Down:Connect(onMouseClick) -- Button1Down is left click, Button2Down is right click