GUI messed up in studio

I’m not sure why, but all of my UI is messed up in Studio. It happened recently, I have not touched anything. It was completely fine before. But the weird thing is it is properly scaled and positioned in-game.

UI messed up in Studio.:

UI completely fine in game:

I have tried restarting my studio and moving the UI to a different place.

1 Like

Have you tried viewing the UI as PC inside studio?

Yes, it seems like the entire position hierarchy is messed up in studio.

I sadly don’t know then. Sorry.

Does this UI have scripts that tween it? Also, are you moving the UI using click and drag or changing its scale size and position through the explorer property settings?

did you use any plugin? and how did you scale them, example : {1,0},{1,0} or {0,1},{0,1}
and where did you safe the file? at the Roblox Clouds or Local File (in your computer)

I used scale, the file is published on Roblox. But I did try moving the UI to a local file as well, same issues. The thing is the UI is positioned correctly in-game; with the same screen size.

There is a single tween acting on the UI. Which just slides the UI down to the center of the screen.

I tried to move the UI through properties.

1 Like

Have you tried to copy and paste the UI into a blank baseplate and test it that way? does it do the same thing?

Yes, but it does the same thing.

It looks like it was a plugin that was causing the issue.

@GreenStom_I mentioned this…

I had a plugin enabled which was causing the issue.