GuiService:SetGameplayPausedNotificationEnabled(false) Does Not Work in Studio Only

Repro file:
SteamingPausedUIRepo.rbxl (543.7 KB)

I’m experiencing an odd bug where calling GuiService:SetGameplayPausedNotificationEnabled(false) does not do anything in studio playtests. I’m playing with IncomingReplicationLag set to 0.15.

The repro file contains a script which calls this function every frame.

local GuiService = game:GetService("GuiService")
local RunService = game:GetService("RunService")

	print("Disabled gameplay paused notification!")

It’s very important for user experience in my game not to show these popups, and I don’t want to record a feature for my game’s producers to have them be confused as to why these popups are appearing in the game again.

What’s odd is that when I test on a phone in a live server (uploaded here StreamingEnabled tests - Roblox), this bug does not happen. This may be because I have really good cell phone service + fiber internet where I am, so it’s hard to find a good environment to test in this case

Still I have a sneaking suspicion that this may A) hit production in the near future due to a feature flag that’s enabled in studio but not the Roblox client, or B) only affects people with worse internet conditions than I can test with.

This doesn’t repro for me when using the client/server play testing in Studio:

Only with what I think we we used to call Play Solo:

The client/server testing is closer to what actually happens in production, and since the problem doesn’t happen there I wouldn’t expect it to occur with live experiences.

Having said that, I am puzzled why it doesn’t work as expected with play solo, and we will investigate that.

Thanks for including the helpful repro place.

1 Like

Awesome. Yeah, just an update—I went into my router settings and limited my bandwidth to 1 Mbps upload/download. I get the freezing but no “Physics Paused” notification so looks like it’s not affecting anything in production as of now.