Handles not correct

Hey, I’m hoping that I’m getting help for this post.

Before, I made a tool that worked correctly.The handle was correctly set and the grip properties was set by hand.

Now the handle don’t match the grip positions and looked like completely offset:

By looking at the CloneTrooper’s Grip Editor plugin, we can see that the grip works… Theorically.

So what should I do to fix that, It doesn’t works ingame or in studio test but it works in studio when parenting the tool to a dummy or even using a grip editor plugin.

I think you should check if the tool is not anchored. If it is, then unanchor it and weld all parts. Also, if you have a part named “handle”, that is very important. Handle is the most important part in your tool. If you don’t have it, then name your main part handle.

Try to make the Weapon Model look like the one on Toolgrip, straight and etc.
And maybe you’ll notice that in the toolgrip it will be different, then just edit it again and try.

Or, you don’t have a “Handle”…

  1. There is a part named “Handle”

  2. Everything is unanchored

  3. And just in case you’ll ask me, cancollide on every parts are disabled

  4. And also I deleted the others parts than handle, still don’t works

  5. deleted the two weldconstraints in the handle, still don’t works

  6. Even a bloxy cola from the toolbox does the same result

Just use the plugin. There’s no issues with it

You didn’t understand the issue + ratio

edit: sorry for saying that but the issue was that there was a transparent custom accessory at the hand