Having a trouble to group things [Solved]

Hello, everyone. Lately, I’m having some trouble to group this medieval house I made. It says “The requested items cannot be grouped together,”. I’ve checked everything in the house but I see no problem.
Also, what is CSG-incompatible? I’m trying to union the house but it says there was something called CSG-incompatible. Please, I really need your help right now.
I also used GapFill, Resize Allign and Archimedes Two while building this house. Not sure if these plugins were the source of the problem.
Some pictures of the house:


The overall view of the house.

First floor

Second floor


How are you selecting the parts to group? By dragging across the screen or by using the Explorer window?

Also have you tried saving, closing, and opening again?

The way I’m grouping the house is by dragging across the screen. I’ll open the studio again to see if it works or not.

Never mind, My friend accidentally put an attachment to one of the parts.

Note: don’t forget to set one of the answers here as a solution instead of putting [Solved] in the title, as that’s not the correct way to do it.

Yeah I was about to say. Attachments and constraints can sometimes be accidentally selected if you drag across the screen and have them switched on. You can hide them under the MODEL tab or just be conscious and deselect them.

Another way to solve it: if you only want to select baseparts and models then the snippet below can be pasted into the command bar after you’ve selected everything.

local sel = {};
for _, s in pairs( game:GetService( 'Selection' ):Get() ) do
    if s:IsA( 'BasePart' ) or s:IsA( 'Model' ) then
        table.insert( sel, s )
game:GetService( 'Selection' ):Set( sel )

Thank you for advice! :smiley: :smiley: