Having issues filtering string, no errors but string isn't filtered

(I don’t use the devforums often, so apologies for any obscurities)

  1. What do you want to achieve? I’m attempting to achieve a system to which the user inserts a string and produces a result that is filtered to be applied to a string-value of some kind.

(This filtering is done on the server, with a normal script, not local)

  1. What is the issue? Include screenshots / videos if possible!
    (I know this should be wrapped in a pcall function, but for now I’d just like to focus on fixing what FinishedFilter returns.

FilteringService is defined as the getservice for TextService.

InputE is string and a UserId is provided, however FinishedFilter returns a string that is not filtered.

  1. What solutions have you tried so far?

I’ve tried running the server on a server out of studio, switched things around and tried using different methods in regards to FilterStringAsync().

I’ve looked at other posts but I can’t find any direct solutions to my issue.

Text doesn’t filter inside Studio, including in Start Server instances. It should work if you publish your game and test it from the website.