Having lots of items in workspace REALLY slows the explorer

After I transferred the Innovation Group build to studio, all parts (~35000) were in workspace. It takes a minute or two to load all the objects in explorer and the game is unusable while it is loading. The game also freezes for 5 seconds when I click on an object in Explorer.

What kind of a Machine are you running? The same scenario works on my work machine, which is not too high end. But I also tried it on a Dual Core 2.3Ghz with 4Gb of Ram, and I’m still not getting the 5 second delays you are talking about.

This is happening when you Freshly start studio? Or after doing some “Play and Reset” sessions?

That happens to me but I just open workspace and close it then open one of my guns in lighting. After I do that when I open workspace it’s fast again. Idk why it works but it does for me everytime.

I thought this was just me! When I reopen studio it works fine for a while until it happens again. Things just become in responsive. (Occasional one-second freezes when clicking items in Explorer.) I can see if I can replicate this and then post a video if you’d like.

This is also happening after a few play and reset sessions. Could this be a problem with the new play solo?

So this behavior happens even if you don’t Play Solo and Reset? Or only after Play Solo and Reset? Because we have a fix in the pipe for Play Solo and Reset slowdown.

I believe it’s just play solo then reset. I’ll make sure when I come home though.

It does not seem to start out with this problem, and I was frequently running test mode and reseting.

CPU Specs:
Intel Quad @2.5Ghz
Win 7

This happens to me except my explorer just keeps adding items over a long period of time instead of freezing altogether. I never use play solo and reset, so it’s not that.

I keep things in explorer like this and I do get lag too when I open Workspace for the first time. Then I just have to wait for everything to load before starting. The wait time is based on how many parts there are in workspace. When I play solo and open explorer; when I walk it’s all stuttery, that is until everything loads. This happens to me in any studio mode with explorer.

Tht sounds like it’s your comouter though.

As far as I know its happened on two individual computers.

This happens to me as well. Usually this happens when I test a script that goes berserk and spawns in thousands of instances, so for me it has happened when run and reset as well. I don’t know about directly after startup though.