HD Admin randomly breaks in game? Please help

Oh, It always works for me. I use it in my Admin Battle game and it never fails. Maybe it’s just not working for you? I’m not sure.

2 Likes

Does it work in a normal baseplate?

2 Likes

yes it does. i have been looking through my game and looking through the explorer tab to see if anything is breaking it, and found nothing.

1 Like

Have you tried making a copy of your game and deleting all your scripts in the copy?

2 Likes

Well, I have no clue but I think HD admin limits you to use it in one game or something, I don’t know.
I think this since my second time using HD admin in my game, it failed.

2 Likes

i just did that, nothing changed, hd admin still doesnt work

1 Like

Try going in another game that has HD Admin (that you don’t own), and see of the problem continues.

2 Likes

so you’re suggesting hd admin only works in ONE of your games?

1 Like

After a quick look through HD Admin’s code, it tries to load a module that you may not own.
Make sure you own this module


If that doesn’t fix it, idk what will.
1 Like

where should i put the script?

1 Like

I believe it should be in the workspace like the regular folder.

1 Like

you dont put it anywhere in your game. just get it, and then the admin will know its in your ROBLOX inventory.
another thing is that required modules dont work that well in studio. try out a live client version of your game instead.
more info on that update of private modules here:

1 Like

i have it in my inventory, nothing is working, though, this thing is always brought up in the output
Screenshot_88

Screenshot_90

1 Like

hmm, thats weird. im using hd admin right now and it works perfectly.
have you tried it in a blank baseplate at all?
also, make sure you are using it in a live client. public modules wont work well in studio.

hd admin works in an empty baseplant and im not sure what a “public module” or a “live client” is

1 Like

oh, i mean live client by pressing the play button on your game instead of playing it in studio
image

done that, didnt work, i played the game with my friends a while ago

1 Like

When you add the HDAdmin module to your game, when the server starts, it should create a number of folders and scripts under ReplicatedStorage for it to function:

HDAdmin (folder)
HDAdminClient (folder)
HDAdminSetup (modulescript)

It is this last one that your instance is complaining about. As these folders and the script are generated automatically by the model, there may be a conflict elsewhere.

Check the requirements on ForeverHD’s main page for the module:

Try creating a blank baseplate and add the HDAdmin model. Does the issue still occur?

i just realised that my hd admin was missing a certain module, i went into an empty baseplate (which hd admin worked in) copied the HDAdminSetup module from repstore, and pasted it into my ACTUAL game’s repstore, but it didnt work.

also, whenever i play my actual game, this pops up in the output:
Screenshot_87
it takes me to line 92 of:

local module = {}

– << RETRIEVE MAIN FRAMEWORK >>
local main = _G.HDAdminMain

– << MAIN VARIABLES >>
function module:SetupMainVariables(location)
main.hdAdminGroup = {
Id = 4676369;
Info = {};
}
main.hdAdminGroupInfo = {}

main.settingsBanRecords = {}
main.alphabet = {“a”, “b”, “c”, “d”, “e”, “f”, “g”, “h”, “i”, “j”, “k”, “l”, “m”, “n”, “o”, “p”, “q”, “r”, “s”, “t”, “u”, “v”, “w”, “x”, “y”, “z”}
main.UserIdsFromName = {}
main.UsernamesFromUserId = {}
main.validSettings = {“Theme”, “NoticeSoundId”, “NoticeVolume”, “NoticePitch”, “ErrorSoundId”, “ErrorVolume”, “ErrorPitch”, “AlertSoundId”, “AlertVolume”, “AlertPitch”, “Prefix”}
main.commandInfoToShowOnClient = {“Name”, “Contributors”, “Prefixes”, “Rank”, “Aliases”, “Tags”, “Description”, “Args”, “Loopable”}
main.products = {
Donor = 5745895;
OldDonor = 2649766;
}
main.materials = {“Plastic”, “Wood”, “Concrete”, “CorrodedMetal”, “DiamondPlate”, “Foil”, “Grass”, “Ice”, “Marble”, “Granite”, “Brick”, “Pebble”, “Sand”, “Fabric”, “SmoothPlastic”, “Metal”, “WoodPlanks”, “Cobblestone”, “Neon”, “Glass”,}
main.rankTypes = {
[“Auto”] = 4;
[“Perm”] = 3;
[“Server”] = 2;
[“Temp”] = 1;
}

if location == “Server” then

  main.pd = {}
  main.sd = {}
  main.permissions = {
  	specificUsers = {};
  	gamepasses = {};
  	assets = {};
  	groups = {};
  	friends = 0;
  	freeAdmin = 0;
  	vipServerOwner = 0;
  	vipServerPlayer = 0;
  	owner = true
  }
  
  main.commandInfo = {}
  main.commandRanks = {}
  main.infoOnAllCommands = {
  	Contributors = {};	--table
  	Tags = {};			--table
  	Prefixes = {};		--dictionary
  	Aliases = {};		--dictionary
  }

  main.morphNames = {}
  main.toolNames = {}
  
  main.commands = {}
  main.playersRanked = {}
  main.playersUnranked = {}
  main.settings.UniversalPrefix = "!";
  main.serverAdmins = {}
  main.owner = {}
  main.ownerId = game.CreatorId
  if game.CreatorType == Enum.CreatorType.Group then
  	local ownerInfo = main.groupService:GetGroupInfoAsync(game.CreatorId).Owner
  	main.ownerId = ownerInfo.Id
  	main.ownerName = ownerInfo.Name
  end
  main.gameName = (game.PlaceId > 0 and main.marketplaceService:GetProductInfo(game.PlaceId, Enum.InfoType.Asset).Name) or "GameNameFailedToLoad"
  main.listOfTools = {}
  main.ranksAllowedToJoin = 0
  main.permissionToReplyToPrivateMessage = {}
  main.logs = {
  	command = {};
  	chat = {};
  }
  main.isStudio = main.runService:IsStudio()
  main.serverBans = {}
  main.blacklistedVipServerCommands = {}
  main.banned = {}
  main.commandBlocks = {}
  
  --Collisions
  for i = 1,3 do
  	"LINE 92" main.physicsService:CreateCollisionGroup("Group"..i)
  end
  main.physicsService:CollisionGroupSetCollidable("Group1", "Group2", false)

elseif location == “Client” then

  main.qualifiers = {"me", "all", "others", "random", "admins", "nonAdmins", "friends", "nonFriends", "NBC", "BC", "TBC", "OBC", "R6", "R15", "rthro", "nonRthro"}
  main.colors = {}
  main.topbarEnabled = true
  main.blur = Instance.new("BlurEffect", main.camera)
  main.blur.Size = 0
  
  main.commandMenus = {}
  main.commandsToDisableCompletely = {laserEyes=true}
  main.commandsActive = {}
  main.commandsAllowedToUse = {}
  main.commandsWithMenus = {
  	["Type1"] = {
  		["laserEyes"] = {"Info", "Press and hold to activate."};
  		["fly"] = {"Input", "Speed"};
  		["fly2"] = {"Input", "Speed"};
  		["noclip"] = {"Input", "Speed"};
  		["noclip2"] = {"Input", "Speed"};
  	};
  	["Type2"] = {
  		["cmdbar2"] = {};
  	};
  	["Type3"] = {
  		["bubbleChat"] = {};
  	};
  }
  main.commandSpeeds = {
  	fly = 50;
  	fly2 = 50;
  	noclip = 100;
  	noclip2 = 25;
  }
  for commandName, defaultSpeed in pairs(main.commandSpeeds) do
  	local setting = main.settings.CommandLimits[commandName]
  	if setting then
  		local limit = setting.Limit
  		if defaultSpeed > limit then
  			 main.commandSpeeds[commandName] = limit
  		end
  	end
  end
  
  main.infoFramesViewed = {
  	Speed = true;
  }

end

table.sort(main.settings.Ranks, function(a,b) return a[1] < b[1] end)

end

return module

the Create collision group error only pops up in my actual game, and not in the empty baseplate