Heavy Studio Crashes since July 30th

Studio is crashing very heavily for me, almost every 5-10 minutes. It happens every time I select multiple parts by holding the Command button and dragging my mouse to select those parts.

OSX Yosemite 10.10.3.

I’ve never had crashing this bad in my experience with Roblox Studio over the years.

Edit: This must be exclusive to plugins that allow us to unselect the mouse cursor. Otherwise you’ll end up dragging parts if you press Command/Control and drag your mouse to select parts.

2 Likes

I’m running Yosemite 10.10.4, can’t seem to replicate this :confused:

Interesting, I’ll try updating. I’ll update this post with an edit with the results.

Still a problem in 10.10.4. Running a 2012 Retina Macbook Pro 15". If that matters.

Also, this isn’t select parts by clicking for each part. It’s clicking and holding, and then dragging to select the other parts. Only then do I crash.

2 Likes

Do you have a place or a plugin that replicates this issue? It sounds pretty serious.

I’m using qCmdUtl


And now that I think about it, I’m hoping this isn’t a qCmdUtl feature. I’m pretty sure click-drag-selecting is a feature in Roblox though.

What I’ll do is boot up qCmdUtl so this Select Tool in studio…

is not selected anymore.

I’m basically 99% guaranteed to crash if I hold Command, and then click-drag my mouse across parts to quickly select them. It actually is so re-occuring, I was able to capture a GIF of it, in one attempt.

Sometimes the Studio Application freezes instead of crashing when I try to drag select many parts.

This also happens in ANY place. Even a brand new place file with a few bricks tossed in so I can try to replicate this bug.
-asimo

2 Likes

The issue seems like it is adorneeing 2 selection boxes to 1 part. I remember this crashing a lot on Windows 8.1 like a year ago. :stuck_out_tongue:

Tried selecting with the plugin just like you showed, still can’t seem to replicate it. :confused:
I’m using a 2012 iMac 21".

Have you tried disabling the plugin to see if that fixes the issue?

I’m getting crashes with cmdutl as well.

This error popped up when it didn’t crash, might not be related:

16:48:56.989 - invalid map/set<T> iterator
16:48:57.037 - Script 'C:/Users/Me/AppData/Local/Roblox/Plugins/CmdUtl 5.0.0/C', Line 513 - upvalue SelectionAdd
16:48:57.039 - Script 'C:/Users/Me/AppData/Local/Roblox/Plugins/CmdUtl 5.0.0/C', Line 620 - upvalue Click
16:48:57.040 - Script 'C:/Users/Me/AppData/Local/Roblox/Plugins/CmdUtl 5.0.0/C', Line 656
16:48:57.041 - Stack End

From that output log, it looks like this is an issue with the plugin.

I’m inclined to believe that something else is going on: this just started but the plugin hasn’t changed in > 2 years, and the only information on that particular error is it occurring in Farming Simulator UK. The particular line the stack says it occurs on is:

game.Selection:Set(objects)

Did something about Selection change in the past few days?

This is the only plugin I know of that let’s me unselect the Select button in Studio. I can’t really attempt a repro with that qCmdUtl plugin disabled. :frowning:

Clicking that Select button myself won’t disable it and clicking other tools and unselecting them seems to make studio

2 Likes

Silent137, as you know, I’m the owner of qCmdUtl.

I can definitely reproduce the crash on my own computer (Windows 10). Due to the nature of the code I’m looking at, and the fact I haven’t touched anything to do with qCmdUtl when this issue propped up, I believe it’s something to do with the ROBLOX Selection service in studio.

I’ll be working to reproduce this issue in a separate plugin.

Please, as SpaceK said, did anything happen to the Selection service?

It looks like there was one change to Selection made that day. We’ll take a look and see if that was the cause, but any repro cases would still be useful!

Edit: Found it. We’ll disable the change for now until it gets fixed. Thanks for finding this one!