Heightmaps Go to New Altitudes!

When will this be an uploaded feature? Instead of just a Beta.

1 Like

Which website do you use to get the colormap from real-world locations?

We haven’t updated the various tools, but we have some changes in mind for the future. Please send feedback and bugs as you encounter them!

Generally, our team prefers to leave features in beta for a couple months to collect feedback and catch any bugs, and then we will roll it out to all users once we believe it’s ready. Correct me if I’m wrong, though, but everyone has access to beta features now, no?

Oh, I just insert a image and BOOM!! the terrain appears the same a my image I upload. Awsome feature you guys, keep going!

1 Like

You made a mountain map. There are so many mountains in your terrain, well worked!

If you’d like to try it, warning its laggy for a minute after you spawn, give it some time, then its not bad…
https://www.roblox.com/games/6410195728/Grand-Canyon-terrain-test-flight

1 Like

It is like mars terrain. But the skybox are missing

Not sure if I should put this here or on Studio Bugs but I only got this issue after I turned on the beta feature


I was pretty stoked to use this update as someone who works with heightmaps frequently. However trying to upload an image fails and instead throws a ton of UI errors and glitches the terrain editor widget thing

In the image above, I tried to reset it by clicking Clear and going back to Import, but it left me with three grayed-out “Generate” buttons

In another case I did the same thing but went to Generate instead of Clear. The results appear to be based off of what I click, as this time I got two selectable buttons instead:

If I stay on the Import tab, I can’t click anything within it.

Trying to close and re-open the terrain editor results in me not being able to open it at all. The glitch does not occur if I don’t try to upload an image.

The glitch also does not occur with any other UI elements that prompt me to upload an image (i.e. the “Texture” property of decals)

I tried this in multiple places, both local files and games published to Roblox, each with the same result. I hope this gets fixed soon, as I’m really eager to use it

2 Likes

Sorry for not replying sooner–something looks wrong with Studio because you see two Generate buttons and no other UI. Could you try restarting and seeing if things are better first? You should see UI like what’s in the original post.

3 Likes

I’ve tried it several times since my original post, also tried removing and re-adding the beta feature to no avail. Here’s a video of what happens when I try to upload an image:

Edit: here’s a copy/paste of the errors it throws, for further investigation
heightmap2errorlog.txt (13.4 KB)

Update: Seems like it got fixed. very happy to finally be able to use thisfeature

1 Like

Sounds really great. Can’t wait to implement this into my current and future games.

I was just testing this awesome feature but sadly I encountered an GUI issue. For some reason the Map Settings overlap with my Edit Terrain settings.

And they don’t fit in the page for some reason…

I tried opening and closing the tabs and switching tabs but it would still persist with the issue. Here is a screen shot of this issue

3 Likes

Hey, can you provide any more detail about how this happened?

If you restart studio does it fix it? If so, can you get it to break again?

2 Likes

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.