Help Disabling sun

im making a space game where i can learn the scale of universe like the ones in videos but the problem arise when i have a black hole where the there is nothing with the black hole except that it has a tiny reflection from the sun which is clearly not there so to fix this i tried making the time to night then i had a different problem where the sky goes away when its night so is there any possible way to totally disable sky?

btw im using a custom space skybox

1 Like

If you use a custom skybox, I’m pretty sure it should disable the sun (I think).

1 Like

Go to your sky then you will find the sun and moon angular size. Set it to zero and it will disappear

or just change the celestial body shown

1 Like

If you want to disable the reflections from the sun, use a material with no reflections like Neon or use a MeshPart and use a SurfaceAppearance with a pure black (or white?) specular map. If you use Neon, you can also use Bloom in lighting and set size and everything to 0 to disable neon glow, since neon uses the glow from BloomEffects.


but i cant do that since im trying to get a black hole-ish effect im using inverted glass material to get that effect but seems like glass have reflection

you can see my black hole in my previous topics

1 Like

yeah i did that and it didnt work

1 Like


Just, to be clear. I do not think this is a Scripting issue. So, I would suggest changing the category into #help-and-feedback:game-design-support since it’s about Lighting.

So, you have to select, Lighting. image Then, you would have to insert in a new Sky after than you would have to disable CelestialBodiesShownimage

When you do that, the Moon and the Sun would disappear from the Sky. Then, you can lower down the brightness, if you do not want to lower down the brightness.

You can use the neon method, which is something like the images, I’m showing.

You can always add a Texture, and change up the material.

You can also, change the Lighting setting to Compatibility which would most likely prevent a reflection and remove shadows. but it would remove shadows. If you don’t want that follow the options above.

You can see more about Lighting, and it’s properties here:

If you tried all that and it didn’t work, leave me another reply. So I can understand your problem more.

If one of my methods worked then mark my post as a Solution Post so other can know that the problem was solved.

1 Like

It seems disabling brightness will give the effect you are looking for

why is it workking for you? but not me thats weird

It’s because the Technology of his Workspace is set to Compatibility.

Why can’t you check my previous post for advice? I’ve already mentioned that. :angry:
His part’s Reflectance is set into 1.


Anyways, Good Luck on your Project! :hidere:

Honestly have no idea, tried on all graphics settings and Future lighting Technology but it still does that. Try test it in-game maybe?

Additionally, you can use ViewportFrames to still render lighted objects (since setting Brightnesss to 0 obviously makes everything dark). This isn’t the case with glass material, sadly, since glass doesn’t render in ViewportFrames, so the black hole has to be in the real world with everything else in the ViewportFrame if you want other lit objects.


thanks for the help but i added an accretion disk which made the black hole to not have any reflection since the disk is brighter than the reflection

and thanks for everybodys help

1 Like