Help! My lighting is bad compared to other games

I need help on Roblox Lighting.

A lot of other game’s tend to still look good and bright with the lowest graphics.

Here’s a picture of my game with high graphics.


Then here it is with low graphics… (LEVEL 1 GRAPHICS)

LEVEL 3 GRAPHICS
As you can see it is very dark around me and everything else just look’s like 2007 lighting type. Let me go ahead and show you differences in another game.

GRAPHICS 1

Why does it only do it to my game?
You can see here there is no dark areas.

Here is my lighting settings.


image
image

As you can see i’m not very professional when it comes to lighting, what is causing this horrible dark area around me when i’m in low graphics?

1 Like

Go to lighting, and make sure your lighting is on the mode “Shadowmap”.

2 Likes

The lighting is ShadowMap. I don’t know why it’s still dark

2 Likes

I see your problem, friend, what happened is that the [Color Correction] changed and that is a bad idea, since it makes the color (Contrast) of the buildings higher, the Lightning (Brightness, Saturation) increases or decreases, etc. I would recommend that you do not work with that since it ruins everything on the map (related to color,stuffs etc) I hope that helps you.

2 Likes

So do I remove color correction?

Yes, since that will help you to remove those high illuminations to the area and calm the atmosphere of the map.

1 Like

Hi! Here’s the things that should get your game with the same lighting as of professionally made games.

Make sure your brightness is set to 2. You can find this on Lighting -> Appearance -> Brightness. Secondly, make sure you have your fog end set close enough that the players don’t see too much far. Make sure the fog color matches the atmosphere you’re looking for. Also, on the color correction properties. Make sure you have your contrast not too high, just enough to get your game clear. I wouldn’t suggest you to touch the brightness too much, leave it to zero. Lastly set the color of the color correction to a matching color of your skybox.


If you did it correctly, this should be your results.

Have fun with your build! Looks really good to be honest :happy2:

1 Like

You don’t have to remove ColorCorrection, just adjust the values. If you want a more contrasted look you increase contrast. If you want more color increase saturation. The shadows are because you have buildings that block lighting. If you want less shadows go from “Shadowmap” to “Voxel” or if you have a few specific buildings that block a lot of light you could turn off the shadows for those buildings.

looks fine as it is, but there are some things that could help.

in camera you can add sub elements like blurr and bloom wich can help smotth things over.

here i would recommend less exposure, more contrast, some blurr, and a tiny bit of bloom.