[HELP] Part stuck after using RoRender

Non-deleteable part.

For context I was using RoRender to generate a minimap. My studio crashed mid render and left this behind:

I have tried removing the plugin, reinstalling studio, unlocking the part, and showing hidden objects. I cant even find the object itself. Any idea how to fix this? I also tried deleting the terrain, that didn’t work either.

Did the Part (I’m assuming it must be Locked if you can’t mouse over it and select it) get saved into some other weird spot like Lighting or another folder?

Could the Part be small and have a BlockMesh in it that makes it appear to be 1000 times bigger than it really is & therefore harder to select because you it’s tough to mouse over the small Part?

How many Parts in your place? Can you just use the Move tool so you can see the axes arrows and find the Part by selecting the item in the Explorer window and using the down arrow to go from item to time?

Its not in any place at all and that game is way too big to go through all parts.I went to the center of where the mesh would have to be and its not there.

If the Offset of the Mesh is set to some weird number then it won’t be in the center of the rendered Part though.
I just wondered if the crash caused the Part to be inserted with strange settings.
You could also just down arrow through the Parts and look for an item that is that purple colour too.

You can remove the purple box with game.Workspace.CurrentCamera:ClearAllChildren()