Help with a data issue?

So, when I tried clicking my animations, it didn’t work. Here’s a screenshot whenever I try to click it.

How can I fix it?

You’re sending too much DataStore requests, which are resulting in those warnings

Try limiting the cooldown on how much you send in your DataStore script

You’re sending a lot of requests to save data, as @Jackscarlett mentioned, are you trying to do an autosave? If so, try to limit the requests to something a bit longer, or just generally shorten the amount of requests

Is that having to do with the problem that I can’t dance, or as in my animations don’t work.image

Depends, what script is handling the Animations to load? & are the Animations saving?

Still getting the error after deleting some scripts, tried finding “1207 etc” in all script none would work. Sending the animation script now.

it seems like you’re using :SetAsync to save the data. It can be easy when using this method to send to many request too fast. I recommend using :UpdateAsync instead, as it is superior when saving data.

local player = game.Players.LocalPlayer
local character = player.Character
repeat wait()
	character = player.Character
until character
local hum = character:WaitForChild("Humanoid")
local emote = hum:LoadAnimation(script.Animation) -- its below the script (parented)
playing = false

	if playing == false then
		playing = true
	elseif playing == true then
		playing = false

I am still getting errors…

I fixed it, I set one of my script to update every 0.01 seconds. But I’m still frustrated with why my animations aren’t working.

First off, you should NEVER set your game to update your data with such a low time in-between. You should check out this article on Data Stores.

Also, you should learn how to load and play character animations. This may help:

I meant if you’re saving the Animation’s ID through a DataStore or not, if you’re using SetAsync/UpdateAsync too often then it can result in that warning

It’s only broken on mobile, I’m having a lot of issues I may just scratch this whole projext :confused:

Here’s the total problems I have,

1: DataStore issue, fixing that but I have to update everything
2: Shift lock & first person issue it is very annoying and I manually turned off shift lock but doesn’t work.
3: Mobile users can’t use animations.

That might just be an end on ROBLOX’s issue, I’ve had the same outcome on Studio before

What do you mean by that? :thinking: Like it works for a computer device but not on mobile?

1 Like

Yes, but sometimes computer doesn’t work and mobile doesn’t either it’s very confusing.

I mean you could try overriding the default “Animate/Animator” animations as your own but I have no clue if that’ll work or not