Help with GUI stuff

I don’t see the problem :thinking: :thinking: :thinking:
elaborate .

1 Like

are you using a screen gui as the parent for anything? if so make sure ignore gui n set is enabled. That might be the issue.

But what is the problem though??
:thinking: :thinking: :thinking: :thinking: :thinking: :thinking:

I believe the UI is not at the top of the screen like the person intended, but I might be wrong.


The reason why the UI is not at the top of the screen is because of GUI n set.

DevHub Article about ScreenGui: ScreenGui

correct imma try your suggestion rq

Didnt really fix it
characters limit

No matter how I change it it looks wrong on some devices

It looks fine on everything besides for these image

I dont see the problem guys!!!
:thinking: :thinking: :thinking: :thinking: :thinking: :thinking:

it all looks the same to me.
There is absolutely no difference.
Is it the color???

what? no they’re talking about the position of it

Anyway, try using this plugin
[Plugin] AutoScale Lite for GUIs - Scale your UI - Resources / Community Resources - DevForum | Roblox

The plugins do not help at all for me. If your UI frame size is something like {0,20} {0,20} then you will have an offset of 20 studs on all devices. However, if you set the offset of the Y and X to 0 then you can resize your frame, place it in the same area, and there should be no offets.

I’m with you, all the examples look identical to me.

OP, can you post the ‘bad’ one and CIRCLE the part that’s wrong?

I feel like i’m being tricked…

which X do you you like better, this one: X or this one: X

It may be because of your screen size. For positioning, you should use the scale option rather than the offset, so the object is scaled for all devices. Here is the fill-in:

{scale_X, offset_X}, {scale_Y, offset_Y}

If I understand correctly, you’re looking to position the UI at the top of the screen?

In Studio’s edit mode, the topbar inset does not exist. To fix this, simply enable the ScreenGui.IgnoreGuiInset property of the ScreenGui.

This will allow you to occupy the 36px usually reserved for the Roblox CoreGui at the top of the screen, without the need for a negative offset value.

It may not seem to have any effect while editing, but you’ll notice your UI is able to be positioned further up the screen in Studio’s test mode(s) and in live servers.


If this doesn’t resolve your issue, please expand on what you’re trying to achieve. The OP is rather vague and screenshots alone don’t always explain what it is you’re trying to accomplish.

1 Like

i think what happened is basically you set your autoscale lite to size not position or something so it keeps the size kind of the same but it can change position

I fixed it tysm this worked and @IceTheOneAndOnly’s suggestion

1 Like

If it issue with size and or position of GUI, it is happening because you set the OFFSET of the Frame, and or the instances inside that. You have to set the Scale of the instances. image
As scale is same on every device, as it calculates position of that resulution (getting the size correct can be pain if you are a moron like I am tho) Also yes plugin that this person suggested can work, but not really as it does cringe for smaller resulution screens.

If you have any further questions, then don’t hesitate to ask.

-Gedeon

Awesome, glad to hear that!
Make sure to mark someone as solution so other people know that the problem has been solved

1 Like