Help with normals for a 3D Model

Hey fellas,

Recently I was attempting to create a UGC concept, and it came out alright, however upon exporting it into the game, I faced an issue that I can only imagine would be with normals.

You can see the brim on the top, however upon moving the camera to the bottom of the hat,

I attempted to Recalculate the Normals in Blender Outside and Inside, but to no avail. Any help would be appreciated :slight_smile:

What order did you do the outside and inside normals?

I think i’m in the right category, since this isn’t a building i’m making in ROBLOX Studio, it’s a mesh.

But I constructed the hat first, and I can’t really really put my finger on the order I did the outside and inside normals

Ight, sorry.

I usually recalculate insides then outsides and it seems to work like a charm. I really hate how this happens, but all I can say is just experiment.

1 Like

Have you tried using auto smooth you can find it in the object options or the triangle with squares on each corner.

All good dw about it lol, thank you for your advice, let me attempt it rq.

1 Like

No I haven’t, can you explain further or leave a tutorial?

here’s a tut for this

Check the Double Sided property box in your meshes Properties, it makes your mesh have 2 faces, basically double sided. It does take up computing power, but not that much.

Try selecting the faces with flipped normals in edit mode and then search “flip normals” and hit enter, it should fix it if the faces normals are flipped.

I believe all you need to do is fill in the hole at the bottom of the cap. Roblox doesn’t register backfaces, so you will need to fill it in.
explanation of your problem:

blender: filling in a hole
  1. Select the borders of the hole (sometimes you can select them as a loop with Alt and right clicking). 2. Press Alt + F to fill the hole with new geometry.

Absolute unit, thank you so very much :pray: