Help with welding a plane

I have a issue. I need all these parts to be welded to the primary part so I can move the plane forward. The issue is, after I welded them all, when I tried to move the primary part the entire plane would break apart. This is a big issue because if the model isnt welded to the primary part, the plane can’t move. I’ve attached some screenshots and videos of the issue.

Video: (Issue starts at 0:30 if you want to skip to it)

1 Like

Did you use Weld or WeldConstraint?

Weld constraint, I used a plugin to weld them all to the primary part.

Huh, I thought they weren’t supposed to break when you moved them? If you create a test model from scratch and weld it does it have the same problem?

I will have to check that, as you can see from the image the are alot of parts and models in the plane.

Something went wrong with the welding process. I’d suggest finding either another plugin or finding a welding script in the Toolbox.

I meant can you make a most basic example with only a few parts, which has the same issue (or maybe doesn’t)?

I believe this is expected behavior, moving the part that is welded to other parts with the move tool is similar to changing .Position for a weld which deactivates (Check the .Active property on the weld) it in order for the part to be repositioned.

Using CFrame or :PivotTo selecting the entire model should counteract this behavior


All the parts of the planes weld contraints part1’s is the main part/primary part. Also, do you have any plugins that will do the same as this? Roblox Studio Model Weld Plugin Showcase - YouTube

I will try this real quickly then.

1 Like

I will check for the active property, but I wouldn’t want to just move the model. For moving the plane I was going to use velocity to push the plane forward.

1 Like

The active property is enabled for the weld contrainsts.

(main is the primarypart of the model)

1 Like

Almost everypart of the model has CanCollide = On if that affects anything.

Yes, It did have the same issue actually, which probably means its the plugins issue. I even tried swapping the Part0 and Part1 to see if it would fix, the model still fell apart.

You are using the move tool in studio correct?


Once you use the move tool when selecting a specific part the weld becomes inactive which you can test using this script:

local weld = script.Parent

while true do
	print("Weld active: ", weld.Active)

The issue is using the move tool on a specific part instead of using the move tool when selecting the model.

1 Like

Oh was this the problem? I was using the move tool to see if the model would work, I will try tweening the part then.

1 Like

Yes this was the problem. When tweening make sure to use .CFrame instead of .Position.

This is documented in the Weld constraint documentation.

1 Like

Can I just change the CFrame of the primary part to a spot on the map and see if the model moves with it?

Yes, you can confirm this by trying it out yourself.

I just testing it with the mini model and it worked just fine, time to test it on the airplane.

1 Like