High Sierra Issues Makes Studio Unusable

I tested it on my 2017 Macbook pro 15" and it’s definitely gotten better but it’s still pretty laggy for me. Everything in the script editor: scrolling, typing has some sort of latency to it. Scrolling feels slow and just not nearly as smooth as it should. When I’m typing I can easily still notice it being slow and noticeably behind on my input. It’s really noticeable if I spam a lot of letters, when I finish it takes almost a full second to catch up. I tested this on both the Color LCD and Generic RGB profiles and the results were the same. Previously Color LCD made the script editor unusable so props to at the very least alleviating the lag on that. This could just be me, I’m not sure.

What version of Studio are you using?

Version 0.324.0.180084. I just tried reinstalling studios and nothing changed. If I make the studio window smaller and smaller it starts to get smoother but still not quite there. I get the worst results having my studio window bigger (maximized not fullscreen although fullscreen is just as bad if not worse…)

That’s the right version and the same symptoms. Can you restart your machine and see if that helps?

Restarted, same symptoms.

The issues I had posted about above just came back after a week of everything working nicely. Only happens in Play Solo now though.

The script editor is fixed on high sierra (although the fix only works for me if I set the launch options for roblox studio to use low resolution mode) but I have a big problem with the 3D/game view. I pretty much have to baby it and tab out and back in and go to a script tab and back so that the game view doesn’t lag like crazy. When I first load into a place it’s super laggy until I tab out and back in. It’s also an issue for clicking anything in the explorer, tabs at the top, etc. They’re super delayed when you click them and everything is just a laggy mess and completely unusable until you do the tabbing. And it constantly happens over and over pretty randomly so like I said, I have to baby it to get studios to work properly… It’s a very annoying experience.

Info about mac:
Macbook pro 2017 15"
On MacOS 10.13.3

1 Like

Getting this on the same computer I posted initially. Super annoying. @Silent137

Good god yes. This is a new bug. You said until you do the tabbing? Is that a work around for this? What do you mean?

I wouldn’t call it a work around or even a fix. It’s a very temporary solution as it only alleviates the lag temporarily. What I mean by tabbing is that when I go into a different application and back or click into a script editor tab and back to the game view it’s fine for a little bit and then something happens where it starts to lag again. But it doesn’t work every time. :confused:

1 Like

Oh yeah, I was already doing that because I got bored waiting lol.

1 Like

It happens so frequently, it’s agonizingly annoying. The only thing I can think of being the cause is maybe a memory leak. @Silent137

Pretty sure it happens every time you do anything? Its unlikely to be a memory leak, because it doesn’t get progressively worse, its just always awful.

1 Like

Not a new bug. I’ve been experiencing it since late last year…

It really only happens for me in Play Solo and sometimes in normal Studio.

Found another issue with Studio in MacOS High Sierra, this one is a pretty big issue. Team create is pretty much unusable on High Sierra and just really buggy and unenjoyable. Not only does it have the same bug above (which is REALLY annoying btw) it also has weird glitches like when you try to see the contents of anything in explorer when I clicked the little drop down arrows they just dissapeared until I went into a different application and back. And on top of that, some of my scripts have super laggy typing. Everything else is fine, scrolling is fine, back spacing is fine, but as soon as I try to type anything it’s SUPER delayed and completely unusable. It’s weird because some scripts have this issue and others don’t. @Silent137

Its back, and worse!! plz fix <3


This happens on all devices, not High Sierra only.

Yeah just started experiencing this yesterday. Never happened at any time before.